Free Support Forum - aspose.com

Image resizing issue with SSRS08

We've been running SSRS 2005 with Aspose.Slides v3 something for a while and all images have been resizing perfectly fine. We just upgraded to SSRS 2008 and the latest version of Aspose.Slides. Now all our images no longer resize correctly. The proportions are all weird (images are really thing but really tall). When looking into the powerpoint file, the scale on the size and position box would say something like "height: 28%, width: 10%" even when the lock aspect ratio box is checked.

Using SSRS 2005 with Aspose.Slides, images would say "height: 28%, width: 28%" and because of this, the images would look great with the proper proportions.

We are using an external image source for our images in the report. When switching to a database source, the images appear to look a little bit better (not as much out of proportion). It still has proportion issues though.

Any ideas?

Hi Stefan,

Since Aspose.Slides for Reporting Services follows the TIFF behavior, you may compare the produced PPT / PPTX with the TIFF versions of the RDL reports. If there is a difference, feel free to share here.

I can confirm that the TIFF version looks exactly like the report, while the PPT / PPTX looks different (as previously explained). Because the TIFF and PPT versions are different, this must be a bug in Aspose.Slides?

On a slightly related note, we are also seeing different behaviour between PPT and PPTX. Text has underline missing in PPTX, and there is a non-existing border appearing on the PPTX as well.

What is the best procedure to go into more details so that you may reproduce these bugs and have them fixed? Just explain a couple of more things in detail or make a sample report for upload?

Hi Stefan,

Can you please provide the output PPT/PPTX alongwith the respective output TIFF of the same effected RTF report so that the issue can be created on our Issue Tracking System for investigation?

Hi Stefan,

I will require one more thing for investigation, that is, said RDL report.

I have emailed you the files requested using the contact button. Please let me know if there is anything else that you need.

Hi Stefane,

An issue with issue id 13266 has been created so that our development team can investigate. This thread has been associated with the issue, so you will be notified automatically as soon as it is resolved.

Hi Stefane,

Thanks for your interest in Aspose.Slides.

Well, the issue 13266 is in the detailed investigation phase. Hopefully, this issue is going to be fixed by the start of next week.

Thanks and Best Regards

The issues you have found earlier (filed as 13266) have been fixed in this update.


This message was posted using Notification2Forum from Downloads module by aspose.notifier.