We're sorry Aspose doesn't work properply without JavaScript enabled.

Free Support Forum - aspose.com

Images appearing after merge

Hi, I have a problem with my Aspose.Words. When merging a simple document, two images appear in the document. They are not present in the template document, but the images are related to the company that the solution is aimed at. I have attached the template and a merged document to this post.

I’m fairly sure that I’m not inserting these images in my code, so where could they come from? I have about 200 templates in this project, and this is the only one that I see the problem with.

Thank you for your interest.

And the merged document.

Hi
Thanks for your request. I can’t reproduce this issue on my side. Most probably these images were inserted by your code. Could you please provide me your code or create sample application that will demonstrate the problem?
Best regards.

I took out the code and made a small console app to test it. When testing the images did not appear in the document. But here is the strange thing:

When merging on our production system, the images appear. But when merging on our development system the images do not appear. The code on the two systems are the same.

So where can the images come from? Can they be hidden in the word document somehow? Or can it be some kind of system specific thing?

I’m all out of ideas, so any help or hints will be hugely appreciated.

Hi
Thanks for your request. Please check the template on the server side. Maybe the template contains these images.
Best regards.