We're sorry Aspose doesn't work properply without JavaScript enabled.

Free Support Forum - aspose.com

Imap client no longer works with GMail

Hi,


We have been using Aspose.Email 1.8 to successfully process emails with attachments in a gmail inbox using the IMapClient for a couple of years now. This stopped working today possibly due to a change in GMail IMAP responses that Aspose.Email cannot handle. I tried 3.2 as well but this does not work either. ListMessages always returns an empty list. Unfortunately, due to the obfuscation, I cannot tell where the problem is. Can I turn on logging of the IMAP messages to see what is being sent and returned from the server?

I have tried a free open source IMAP component as a replacement and that works fine so GMail is still accessible.

Can you please look into this and provide a solution for Aspose.Email 1.8?

Regards,
Paul.

Hi Paul,


We are sorry for the inconvenience caused.

I was able to reproduce this issue at my end using the latest version of Aspose.Email for .NET 3.2.0. It seems that there are some recent changes from Gmail end that might have affected this functionality. I have logged it as NETWORKNET-34050 in our issue tracking system for further investigation by our development team and will write back here as soon as there is some information available in this regard.

We have experienced the same issue as well.

We are currently watching our customers go down like flies.

Is there any sort of ETA on the fix?

Hi Chris,


We are sorry for the inconvenience caused to you. After checking the status of this issue from our issue tracking system, I can find that the issue has been scheduled to be fixed in the upcoming release of Aspose.Email for .NET 3.3.0, which is due by the end of this month.

Could you please create a new thread and report the same problem? I’ll associated the logged ticket with your thread as well so as to make sure that the fix is included in the upcoming version of Aspose.Email. Looking forward to assist you further.

This issue is quite annoying/Blocking and version 3.3.0 is only expected at the end of the month, a hot fix would be appreciated.

Hi Faessler,


We are sorry for the inconvenience caused.

Development team is currently investigating this issue on priority basis and will try to solve it as soon as possible. Once the issue is fixed, a request will be put for a hotfix so as to avoid the problem.

The issues you have found earlier (filed as NETWORKNET-34050) have been fixed in this update.


This message was posted using Notification2Forum from Downloads module by Aspose Notifier.
(1)