We're sorry Aspose doesn't work properply without JavaScript enabled.

Free Support Forum - aspose.com

IMAP: Error reading messages with parameter retrieveRecursively set to True

Hi,
I'm trying to use the retrieveRecursively parameter of the ListMessages function of the ImapClient object. My code is very simple:

Dim messages As ImapMessageInfoCollection = imapClient.ListMessages(ImapFolderInfo.InBox, True)

This line throw an exception with this error message:

AE0011 BAD Error in IMAP command FETCH: Invalid messageset

Is there an alternative way to retrieve all messages from a folder recursively?

Thanks,
Alessandro

Hi Alessandro,


Thank you for posting your query.

We have tested this issue at our end using the latest version of Aspose.Email for .NET 5.5.0 and couldn’t reproduce the same issue at our end. The messages are retrieved properly from the specified inbox folder recursively and there is not exception raised. Please try it with this latest version and share your feedback with us.

Hello,

I’m already using the last version of the library.
I add a detail: I get the same error if I select a folder without messages and execute the “classic” ListMessages function, without recursion.

Alessandro



Hi Alessandro,


We have tested this issue with the latest version and an empty inbox folder on our Exchange server. There is no exception raised. Following is the code that we have used at our end. In order to investigate the issue further, could you please create a test account on some public email server and share its credentials with us that we can use to reproduce the issue at our end and report it? We shall look into these for assisting you further.
Unfortunately, the problem occurs in the mailbox of one of our customers and I can not provide credentials. We tried with other mailboxes of the same service (http://www.pec.it/) without detecting the error. I don't know if there's something special about that mailbox .
For completeness, the detected error is not what I have indicated previously, but is slightly different:

AE0010 BAD Error in IMAP command FETCH: Invalid messageset

The code is not AE0010 but is AE0011.

Thanks,
Alessandro

Hi Alessandro,

We are sorry to share that we won’t be able to investigate the issue further until a test account is available for our analysis. We have had a test account on this server and that is working fine. It is similar to what you have also mentioned that other mailboxes are working fine. Even if we share the information with our Product team, they won’t be able to investigate the issue at their end in such a situation.We appreciate your understanding in this regard and will be glad to assist you further once a test account is available for our analysis.