We're sorry Aspose doesn't work properply without JavaScript enabled.

Free Support Forum - aspose.com

Importing HTML Render Problems

Using the latest version of Aspose.Words (i.e. 11.8) I've run into some rendering issues when importing the following sample html:



Test





Heading 1


Paragraph 1


Paragraph 2


Paragraph 3



Heading 1 is correctly center-aligned however Paragraph 1 is also (incorrectly) center-aligned. Paragraph 2 and Paragraph 3 are correctly left-aligned

None of the bottom margin values are applied. Heading1 and Paragraph 1,2 & 3 all end up with space after set to Auto (i.e. 14pt)

Can anyone help explain why I'm seeing these issues?

Hi Simon,


Thanks for your inquiry. While using the latest version of Aspose.Words i.e. 11.8.0, I managed to reproduce both of these issues on my side. I have logged these issues in our bug tracking system. The issue IDs are WORDSNET-7172 (Paragraph alignment problem) and WORDSNET-7173 (SpaceAfter problem). Your request has also been linked to these issues and you will be notified as soon as they are resolved. Sorry for the inconvenience.

Best Regards,

Hi Simon,


Thanks for your patience. It is to inform you that your ‘Paragraph Alignment’ issue has been implemented in the current code base and the fix of WORDSNET-7172 will be included in the next release of Aspose.Words (11.10.0) that is due out at the end of this month. We will inform you as soon as the new release is published.

Best Regards,

The issues you have found earlier (filed as WORDSNET-7172) have been fixed in this .NET update and this Java update.


This message was posted using Notification2Forum from Downloads module by aspose.notifier.

The issues you have found earlier (filed as WORDSNET-7173) have been fixed in this .NET update and this Java update.


This message was posted using Notification2Forum from Downloads module by aspose.notifier.