We're sorry Aspose doesn't work properply without JavaScript enabled.

Free Support Forum - aspose.com

INCLUDEPICTURE problem

Hi,

I am using Aspose.Words 4.1.1.0 (latest I believe). When having this field in my Word document:

{ INCLUDEPICTURE "MERGEFIELD GraphLink \* MERGEFORMAT" \* MERGEFORMAT }

the field "GraphLink" does not get updated. However, when I have a field like:

MERGEFIELD GraphLink \* MERGEFORMAT

it does get updated. The field "GraphLink" is filled by a Recordset from SQL Server SELECT using ExecuteWithRegionsADO.

I remember that when I, a while ago, did the same with version 3.x it was still working. I am currently running on Vista Ultimate and MS Office 2007.

Thank you.

The field { INCLUDEPICTURE "MERGEFIELD GraphLink \* MERGEFORMAT" \* MERGEFORMAT } does not look like a valid merge field to me. Still, please attach the document with such fields, I will check if we can support these fields in the future.

Best regards,

Hi,

Attached the document in an email to sales@aspose.com (replied to the one that was sent to me).

Well, the merge field was working in the 3.x version (cannot remember which one, cause I did that more than a year ago).

The merge field "{ INCLUDEPICTURE "MERGEFIELD GraphLink \* MERGEFORMAT" \* MERGEFORMAT }" is supported in Word. You can find many references and examples on the web on how to include pictures in mail merge letters and labels.

Many thanks. Kind Regards, Jurgen

Ok, I will research the issue as soon as I will receive the document from sales team.

Bets regards,

I have received the document from the sales department but looking as hard as I can I don't see any INCLUDEPICTURE field in it. Please let me know where I can find it.

Although this might be valid in MS Word, this will approach will not in Aspose.Words.

Since that you mentioned it, I now realize it might have worked in Aspose.Words before 4.0. If you want a brief explanation, it is related to the work we've done in Aspose.Words 4.0 to improve graphics. We did not anticipate INCLUDEPICTURE field used in this way and therefore it will not work this way.

A more detailed explanation: Aspose.Words 4.0 had a major upgrade of how drawing objects are handled and INCLUDEPICTURE fields in the document are now represented by a Shape object. Basically, when you load such a document into Aspose.Words, it will have a Shape object with image source set to text "MERGEFIELD blah blah". MERGEFIELD will not be a field and therefore will not be picked up by the Aspose.Words mail merge engine.

I will log this as a thing to consider, maybe we will rever how INCLUDEPICTURE fields are handled, but cannot promise at this stage.

To workaround, remove the INCLUDEPICTURE field, leave the MERGEFIELD and change the field name from GraphLink to Image:GraphLink. This is an "extended syntax" that Aspose.Words mail merge engine understands and it will try to load an image and insert instead of the merge field.

Previet Roman,

many thanks! That worked well with the Image tag. Excellent support as usual.

Paka, Jurgen

The issues you have found earlier (filed as 1502) have been fixed in this update.


This message was posted using Notification2Forum from Downloads module by aspose.notifier.