We're sorry Aspose doesn't work properply without JavaScript enabled.

Free Support Forum - aspose.com

Inconsistent excel protection behavior

Dear Team,

We are experiencing a strange issue with excel protection. We have 2 excel password protected base templates. We use Aspose.cells to open this template and do some manipulations and finally save it as new file.We are not calling any Protect/Unprotect methods during this process. But strangely one of the work book is getting unprotected automatically (Other template is fine and protection still exists). The password got removed somehow for one workbook.

Please help us in this regard.

Thanks
Anish

Hi Anish,


Please provide the spreadsheet in question along with the code snippet (preferably a sample application) to replicate the said problem on our side. We will thoroughly review the scenario to assist you further in this regard.

Before you move forward to provide the above requested, please give a try to the latest version of Aspose.Cells for .NET 8.5.0 and see if you still can replicate the problem.

Dear Team,


Thanks for the response. Please find the sample application and templates (inside templates folder) attached

Thanks
Anish

Hi Anish,


Thank you for the samples and code.

We have evaluated the presented scenario while using the latest version of Aspose.Cells for .NET 8.5.0, and we are able to replicate the said problem. We have logged this incident in our bug tracking system under the ticket CELLSNET-43742 for further investigation. Please note, we may also require the password for the spreadsheets for through investigation so it would be appropriate to share the passwords for both input spreadsheets now.

Thanks for the prompt action.

Please use “test” as the passwords for both the workbooks.

Anish

Hi Anish,


Thank you for providing the password. We have passed on this information to the product team. Please allow us some time to properly analyze the scenario, and get back to you with updates in this regard.

Hi again,


This is to inform you that the ticket logged earlier as CELLSNET-43742 has been marked resolved. We will shortly provide the fix here after performing quality assurance and incorporating other enhancements.

Hi,


Please try our latest version/fix: Aspose.Cells for .NET v8.5.0.1

We have fixed your issue “CELLSNET-43742” now.

Let us know your feedback.

Thank you.

The issues you have found earlier (filed as CELLSNET-43742) have been fixed in this update.


This message was posted using Notification2Forum from Downloads module by Aspose Notifier.