Inconsistent Thumbnails with Different Size for the Same Presentation Slides


I am trying to generate three different size thumbnails for this single slide PPT, in each thumbnail the output changes quite a bit, particularly the arrow.

It doesn’t get resized as per the thumbnail size and instead goes outside the triangle, giving a totally different view wrt the original slide.

Attaching files.


Hi Rajiv,

I have observed the output shared and have observed the inconsitencies. Can you please share the sample code that you have used on your end to reproduce the issue. I will investigate the issue further on my end to help you out.

Many Thanks,

Hi Mudassir,

My apology for responding on this thread after a long time.

This issue was actually found during a release cycle that we were in middle of, but then it was deferred from that release due to third-party dependency, and hence it went out of the sight for a while. I am now just trying to consolidate and take up some of these legacy issues we have in our bucket, and see if they can be quickly knocked off.

I re-tested this issue in your recent major release (i.e. Aspose slides 8.0). The behavior is still the same.

Can you just tell me is it necessary for us to share our code with you ? I think I may have to take permission from the higher-ups even if it’s a simple code. Can’t you just make a sample program yourself to extract thumbnail from a given PPT using Aspose slides ? I guess it should not be difficult, and I am sure you’ll be able to reproduce the behavior for small size thumbnails (something like 40x40 pixels).


Hi Rajiv,

I have worked with the presentation file shared by you and have generated the slide thumbnails with custom dimensions as shared by you in your images using Aspose.Slides for .NET 8.2.0. I have been able to observe the issue of improper arrow rendering in thumbnails and an issue with ID SLIDESNET-34967 has been created in our issue tracking system to further investigate and resolve the issue. This thread has been linked with the issue so that you may be automatically notified once the issue will be resolved.

We are sorry for your inconvenience,

Thanks Mudassir for quick update …

Just one clarification, we’re using Aspose Slides for Java, I hope the bug you filed in your system has that info. There have been instances in past when the issue gets marked as fixed in .NET version but continues to be there in Java version.


Hi Rajiv,

Thanks for sharing the further details. Actually, in your earlier post the Aspose.Slides product was not specified and only version was mentioned so that is why the issue has been verified and reproduced with Aspose.Slides for .NET latest version. Aspose.Slides for Java is autoported from Aspose.Slides for .NET, so any issue prevailing in Aspose.Slides for Java is first resolved in Aspose.Slides for .NET and then ported to Aspose.Slides for Java. I have created an issue with ID SLIDESJAVA-34223 in our issue tracking system for Aspose.Slides for Java as well. We will share the notification with you as soon as the issue will be resolved.

Thanks and Regards,

Thanks Mudassir …

The issues you have found earlier (filed as SLIDESJAVA-34223) have been fixed in this update.