We're sorry Aspose doesn't work properply without JavaScript enabled.

Free Support Forum - aspose.com

Incorrect Formula(cell.formula and ExternalLink)

Hello again!


This is pretty much the same problem I discussed in my last thread. I incorrectly said the issue was resolved. The problem is that when returning a formula from a cell Aspose garbles up the formula, so with a cell containing the formula

=AVERAGE(‘C:\Aspose\SubFolder[Datasource.xls]Data’!$B2:$N2)

Aspose returns

=AVERAGE(’[SubFolder\Datasource.xls]Data’!$B2:$N2)

While a slight variation is manageable what Aspose returns is not in a usable state. There is no way to safely identify the location of the datasource, so I can’t open the file and check its contents. The problem also occurs in the ExternalLink where the datasource is SubFolder\Datasource.xls.

I’ve written a small NUnit test and two simple spreadsheets to illustrate the issue. Tested under Aspose 5.0.0.0 and 4.9.1.6.

Kevin

Hi,

Thanks for providing us the template files with sample code.

I can find the issue as you have mentioned. We need to investigate the issue. I have logged your issue into our issue tracking system with an id: CELLSNET-18297. We will get back to you soon.

Thank you.

Hi,

Please try the attached version.We have fixed your issue.

Thank you.

Formula does indeed return what I expect.

Still an issue with workbook.Worksheets.ExternalLinks[0].DataSource returning "SubFolder\\Datasource.xls". If I recall correctly the Excel Interop convention is that the array of external datasources returns the file name only so we would expect Datasource to be equal to Datasource.xls(or whatever the name of the spreadsheet data source is). Still it’s passing my tests here so I’m happy.

Thanks a million

Kevin

Hi,

Yes, it returns “SubFolder\Datasource.xls”. We will get back to you to further explain it.

Thank you.

Hi,

Please try the attached version and let us know if it works according to your need now.

Thank you.

The issues you have found earlier (filed as 18297) have been fixed in this update.


This message was posted using Notification2Forum from Downloads module by aspose.notifier.