Free Support Forum - aspose.com

Installing Aspose Words license

Hi,

I have had the evaluation version for some time, and I purchased Aspose Developer license a few days ago. I tried to install the license in the following steps :

1. put the Aspose.words.lic file in the same location as my Aspose.Words.jdk16.jar file. ie.C:\Program Files\Apache Software Foundation\Tomcat 5.5\common\lib

2. Put the following code in the Servlet, before I call Aspose.
com.aspose.words.License license = new com.aspose.words.License();
try {
license.setLicense(“Aspose.Words.lic”);
} catch (Exception e) {
e.printStackTrace();
}


However, I still get the ‘Evaluation Version’ message in the word docs I generate. What am I doing wrong? Help appreciated. I have a client demo coming up soon.

My earlier offline live chat request was completely ignored , so :frowning:



thanks for the help,

Sami.

Hi

<?xml:namespace prefix = o ns = "urn:schemas-microsoft-com:office:office" />

Thanks for your inquiry. Please make sure you have set license in correct place, i.e. before creating Document and only once per application domain. Please see the following link for more information:

http://www.aspose.com/documentation/.net-components/aspose.words-for-.net-and-java/when-to-apply-a-license.html

Also, please check the points described in “Licensing” section in FAQ:

Hope this helps.

Best regards.