We're sorry Aspose doesn't work properply without JavaScript enabled.

Free Support Forum - aspose.com

Invalid color space type?

I have been trying to figure out this for hours…

Everything was working I thought until I created a PDF document that seems to be more than a page. And then I get this error

It seems I must create a new section?? table or something? If I am to continue on the next page.

any ideas?

Dear punkouter,

Thanks for your consideration.

Could you post your code/xml here or email it to us so that we may advise what to do next.

I used the alphabetical report as a example to work from… I have tried creating a new table each 3 rows of info but when the report spans over a page I still get INVALID COLOR SPACE


While resultReader.Read()
If i = 3 Then
Table = NewTable(pdf, section)
i = 0
End If

i += 1

strCrossingID = CType(resultReader.GetValue(0), String)
strStreet = CType(resultReader.GetValue(1), String)
fCost = Convert.ToInt32(resultReader.GetValue(2)).ToString()
fRiskindex = Convert.ToInt32(resultReader.GetValue(3)).ToString()
strWD = CType(resultReader.GetValue(4), String)
strSSM = CType(resultReader.GetValue(5), String)

AddRow(section, Table, strCrossingID, strStreet, fCost, fRiskindex, strWD, “Helvetica”)
AddRow2(section, Table, strSSM, “Helvetica”)
End While

AHHH! figured it out… I added this


border.Top = New GraphInfo()
table1.IsFirstParagraph = True


to each table and it works


though if someone could explain to me why those 2 lines are needed that would be nice

Hi,

We are testing out the evaluation version for a possible purchase.

While trying to create a sample report, I ran into the same issue.

I based my report of the Catalog example that came with the demo, but not sure what is going wrong here.

Any ideas? I will email the code-behind and XML if requested.


grueluks,

please email your code-behind, XML, PDF and description of the issue ASAP.

Thanks for your contribution.

I receive this error very often.
For example, it occurs when the fitwidth of the table cell is less then string which should be written in this cell.
You can simulate this error in your Invoice report:
change the following rows in the AddTable and AddRow functions by the following:

cell2Row1DetailTable.FitWidth = 50;
(this is the fitwidth of the Product Name table)

Can you explain, why the string is not wrapp in this case?
How can I specify wrap property?

Hi all,

Since this problem has bugged so many guys we will try to solve it completely, ASAP.

Thanks for your patience.

Looking forwardly

Hi all guys,

We’re working on these issues and plan to deliver a fix to you very soon.

My MSN Messenger account is aspose@hotmail.com. Feel free to contact me at MSN for the latest progress.

I also received this error, but for a completely different reason. See the entry under “[Collections and references](http://forums.aspose.com/ShowPost.aspx?PostID=641)” dated 06-12-2003 03:03 PM.

Dear Marksman,

Thanks for your consideration.

Please see the reply under “[Collections and references](http://forums.aspose.com/ShowPost.aspx?PostID=641)” thread.

The PDF file must be OK and there is no problem with Adobe either. The Problem is with the Uploaded pdf file. If the PDF file is uploaded with ASCII Transfer Mode, then only you get such error message. I have my personal experience, coz i sell eBooks on the net. I uploaded the pdf file in ASCII and i got the message you are getting. However, when I transfered the pdf file in binary mode, everything was fine and working.

Hello Keyur,

Thanks for using our products.

Can you please share how you are generating the PDF document, and also please share the error message that you getting. However, it would really be great if you could share some details regarding the application to which you are uploading the document.

If possible, please share some application that can help us in replicating this problem at our end. We apologize for your inconvenience.