We're sorry Aspose doesn't work properply without JavaScript enabled.

Free Support Forum - aspose.com

"Invalid PatternType string value"

I got this exception with this stacktrace:

at . (String )
at ​ . ( )
at ​ . ( )
at ​ . ( )
at ​ . ( )
at . ()
at . ()
at . (Workbook , Stream , LoadDataOption )
at Aspose.Cells.Workbook. (Stream , LoadOptions , Boolean )
at Aspose.Cells.Workbook. (String , LoadOptions )
at Aspose.Cells.Workbook…ctor(String file, LoadOptions loadOptions)
at iXLink.Excel.Aspose.ExcelApplication.GetWorkbook(String filename, Boolean readOnly)

Is this a known issue?

@brunojuliao,

Thanks for the stack trace.

This is not the known issue. It looks like you are loading the file via Aspose.Cells APIs and got the exception. Could you share the template file and paste your sample code here, we will check it soon.

AsposeTest.zip (217.1 KB)

When I changed the file name, it worked. When I changed the file content, it worked.

@brunojuliao,

We have tested the sample project and observed that if we use the XLSX file as it is, the exception is raised. Then we changed the file contents and saved it back on disc. This time code ran successfully and no issue was observed. However when we changed the file name, exception is still there, so it does not seem to be an issue with the file name. Please verify it again that does it work after changing file name or not. It seems to be an issue with the file contents and not with the file name. Once you provide us your feedback, we will log issue about the exception while loading the file.

You’re right. My bad. When I tried changing the filename, I used the “save as” from excel instead of renaming through SO. Just retried the right way and the error, as you stated, occurs even after renaming the file.

@brunojuliao

I was able to observe the exception by using your sample application and input file. I have logged a ticket with an id “CELLSNET-46199” for your issue. We will look into it soon.

Once we have an update on it, we will let you know here.

@brunojuliao,

This is to inform you that we have fixed your issue now by ignoring an invalid setting about pattern “<patternFill patternType="grey125"/>” in the file. We will soon provide you the fixed version after performing QA and incorporating other enhancements and fixes. By the way which tool you used to create this file?

Thanks :wink:

@brunojuliao,

Please try our latest version/fix: Aspose.Cells for .NET v18.6.4:
Aspose.Cells for .NET v18.6.4 (.NET 2.0)
Aspose.Cells for .NET v18.6.4 (.NET 4.0)

Your issue should be fixed in it.

Let us know your feedback.

It worked. Thanks a lot :slight_smile:

@brunojuliao,

Good to know that your issue is sorted out by the new fix/version. Feel free to contact us any time if you need further help or have some other issue or queries, we will be happy to assist you soon.

1 Like

The issues you have found earlier (filed as CELLSNET-46199) have been fixed in Aspose.Cells for .NET v18.7. Please also check the document/article for your reference: https://docs.aspose.com/display/cellsnet/Installation

The issues you have found earlier (filed as ) have been fixed in this update. This message was posted using BugNotificationTool from Downloads module by MuzammilKhan