We're sorry Aspose doesn't work properply without JavaScript enabled.

Free Support Forum - aspose.com

Is Agile Encryption supported by v9.8.0.0

Hello,

I am using Aspose.Words.dll v9.8.0.0.

I am converting doc to mhtml format. I am able to convert documents created using MS Word 2007. But when I try to convert documents created using MS Word 2010, I am getting error as
“The document is encrypted using Agile Encryption and this is currently not supported.”
Also note that even though I am using MS word 2007/ 2010 , I am saving documents in .doc format that is Word 2003 format.

I have gone through your one of the posts where it is mentioned that you support Agile Encryption.(Refer to point #10 in Winword file conversion)

Can you please guide on this issue?

Regards,
Shashi

Hi

Thanks for your request. No, Aspose.Words 9.8.0 does not support Agile encryption. Agile encryption is supported by Aspose.Words for .NET starting from 10.6.0 version. You can download it from here:

http://www.aspose.com/community/files/51/.net-components/aspose.words-for-.net/category1188.aspx

Best regards,

We are having license for v9.8.0.0.

Can we use same license file and upgrade to v10.6.0?


Hello

Thanks for your request. Every Aspose license carries one-year subscription for free upgrades to new versions released during this time. So, you can just check the expiration date of your license. To check an expiration date of your license open the license file using notepad. You will see the following tags:

20110218

It means that you can free upgrade to version of Aspose.Words published before 02/18/2011.

Best regards,

Hello,

As per your reply I have checked the expiry date present in license file. It is showing 20120429.

I have license purchased for v9.8.0.0. When I tried to use this license for v10.6.0, I am unable to do so.

Could you please let me know whether this license will work with v10.6.0 or not? If not then what is the procedure to get new license file?

Also is there any standard procedure for upgrade?

Thanks.

Hello

Thanks for your request. I think, this could be because you license file is corrupt. You can send your license to me, and I will check it on my side. Please see the following link to learn how to send the license file.

http://www.aspose.com/corporate/purchase/faqs/send-license-to-aspose-staff.aspx

Best regards,