Free Support Forum - aspose.com

Is Aspose cells compatible with SSRS 2017?

Hello,

we are upgrading SSRS to 2017 and as I am currently testing aspose as a possible reporting solution I was trying to install the latest version 18.2.3

The MSI install did not modify the configuration files but I then added the required blocks inside the .config files and copied the dll file over but I do not see any of the aspose extensions in SSRS.

Before I spend more time investigating could you please confirm that aspose is compatible with SSRS 2017? I saw in the blog post that aspose for words is compatible with sql server 2017 so I assume it is the same here but just want to be sure.

thanks,

Charlie

@Charlie.R

Thanks for using Aspose APIs.

We are afraid, it is not compatible at the moment but we have logged this task in our database. We will look into it and support it as soon as possible.

This issue has been logged as

  • CELLSRS-534 - Make Aspose.Cells for Reporting Services Compatible with SSRS 2017

@Charlie.R,

We have added the new feature for supporting SSRS 2017 (only supported in Windows platform). Please try fixed version: Aspose.Cells for RS v18.2.6.

Let us know your feedback.

@Amjad_Sahi I di not see a 2017 Folder, should I simply use the DLL in the 2016 folder?

thanks,

Charles

@Charlie.R,

Yes, you may try it.

Let us know if you find any issue.

@Amjad_Sahi I have tried to install this version first on 2016 to test the other issues I had but everything is now broken.

Reports are being outputted empty, I have tried to uninstall and revert back to 18.2.1 but it is not working any better.

If I try to recreate a report which is empty with the older version but still getting similar issues, if I return a basic table output without setting the attribute I see the first line. If I set the attribute the output is empty.

Not sure how to troubleshoot and this is obviously causing an issue on my end. How can I make sure ASpose is properly uninstalled? (the installer fails on the server so I just copy the DLL manually)

thanks,

Charlie

@Charlie.R,

If you have installed via MSI Installer, you may easily uninstall it using the Windows control panel, see the document for your reference:
https://docs.aspose.com/display/cellsreportingservices/Uninstalling+Aspose.Cells+for+Reporting+Services

If you need to install Dlls version, see the document for your reference:
https://docs.aspose.com/display/cellsreportingservices/Using+DLL+Only

Yes that’s what I did, so it would seem my install is correct then. Not sure why I am now unable to create new reports or they download empty.

@Charlie.R,

Please give us your environment details (OS, MS SQL Server, etc.) and capture demo video or series of screenshots to highlight the issue, we will evaluate your issue soon.

Not quite sure hot to make a video.

but basically everything was working until I tried the new version. Now I cannot create new reports, I went back to version 18.2.3 but it did not fix the issue. Do note that existing reports still function as expected. This is very similar to the issue highlighted there:
https://forum.aspose.com/t/total-line-no-longer-appearing/175522/16 were I can see data in SSRS but not in Aspose

pic1:
I can create a simple aspose table
pic2:
if I preview the report first line of data will display data (as expected)
pic3 and pic4:
If I then create the attribute for the codes, and then preview, no data is returned.
pic5:
If I run the same report in SSRS all the data shows.

I have also attached the RDP report.
No_data.zip (374.6 KB)

The server is running on SSRS 2016, I am testing on Excel 2010 and 2016

thanks

@Charlie.R,

That is strange. We have to look into it but have no clue why it is not working now with even older version (v18.2.3) where it was working before when creating new reports. I think you should try on different machines to evaluate the issue.

Also, I cannot unzip your attached zipped archive which contains the screenshots and report definition file, may be my zip tool is older but it works for other zipped archives. We appreciate if you could zip the files with some different tool and re-attach it again. Also provide us your environment details (e.g OS).

I installed the addin on a new machine with excel 2010 so it never had aspose on it.

for the server I only have the one production server (which is bad because now we cannot do anything with aspose)

The installer fails on that machine, do you also add stuff in the registry?

the server is running windows server 2016, mssql 2017 and ssrs 2016 (we downgraded from 2017 since you were not compatible)

I am also re-uploading the zip: NNM_TEST.zip (416.9 KB)

actually not sure if this could be an issue, but in version 18.2.3 the file in Bin\SSRS2016 actually has a version number of 18.2.1 so maybe that has a compatibility issue if excel is then on 18.2.3?

@Charlie.R,

Thanks for the zipped archive containing the RDL file and screenshots.

We need to evaluate your issue thoroughly on your given environment with latest version/fix. We have logged your samples and screenshots against your issue into our database for investigation. Once we have an update on your issue, we will let you know.

And yes, the installer does add stuff into registry especially for client tool (add-ins) for MS Excel. It is best you use installer to install the latest version it should add add-ins to Ms Excel and register certain things fine .

Your findings is right as we noticed the version of Aspose.Cells.ReportingServices.dll assebmly is v18.2.1 when installing the Aspose.Cells for RS v18.2.3 via its installer.

Hopefully we will get back to you soon.

@Charlie.R,

We were able to find the issues. Hopefully we will figure these out before the end of next week. Once the issues are sorted out, we will share the fix for your evaluation.

@Charlie.R,

Please find attached the latest fix/version: Aspose.Cells for Reporting Services v18.2.7 (attached).

It is a fixed version for SSRS 2016 and 2017.

Let us know your feedback.
ACRS2017.18.2.7.zip (4.8 MB)

@Amjad_Sahi I am looking at version 18.2.9 and there is no SSRS2017 folder, should we use the DLL in SSRS2016 for SSRS 2017 as well?

thanks,

Charlie

@Charlie.R,

Yes, Aspose.Cells for RS version for SSRS 2016 should also work fine on SSRS2017.

Let us know if you find any issue.

The issues you have found earlier (filed as CELLSRS-534) have been fixed in this update. This message was posted using BugNotificationTool from Downloads module by Amjad_Sahi