We're sorry Aspose doesn't work properply without JavaScript enabled.

Free Support Forum - aspose.com

Issue in generating the Thumbnail of pptx slide

Hi,

I am generating Thumbnail of pptx while generating the thumbnail the mark sign get changed. Can you please help what exactly the issue is?

I am using Aspose slide java version 18.10.

Below is the resources which can help in investigation.
POC.zip (78.7 KB)

Zip contains presentation and expected result and actual result which I am getting.

Code snippet I used :

	 /** Activate ASPOSE license.*/
	License license = new License();
	license.setLicense("Aspose.Slides-new.lic");  
    if (license.isLicensed()) {
	    System.out.println("License is Set!");
	}
	
	String dataDir = "/var/www/html/test/poc/";

	//Instantiate a Presentation class that represents the PPTX file
	Presentation pres = new Presentation(dataDir + "inputPPTX.pptx"); 	
	//Create a image
	BufferedImage image = pres.getSlides().get_Item(0).getThumbnail(1f, 1f);
	 
	//Save the image to disk in JPEG format
	ImageIO.write(image,"jpeg",new File(dataDir + "actualResult.jpg"));
	
	System.out.println("image is ready");

Thanks,
Saquib Shaikh.

@saquibs,

I have observed the issue shared by you and have found that you are using a fairly older version of API. Can you please try using latest Aspose.Slides for Java 20.4 on your end and share the feedback with us.

Hi,

Even tested with latest version of Aspose Slide Java that you have mentioned i.e 20.4 still I am getting same result. Thumbnail icon is incorrect.

@saquibs,

I have worked with the presentation file shared by you using Aspose.Slides for Java 20.4 on my end and have not been able to reproduce the issue. The generated output is attached for your reference too. The issue you are facing is due to missing bullet font on your end. Please make sure that font used for bullet is available on your end.
actualResult.jpg (13.5 KB)