Free Support Forum - aspose.com

Issue with font-size in table data and column chart not rendering the applied opacity

Hello Aspose Team,

We are facing these issues when trying to generate PDF from the following templates.zip (160.2 KB)
.

  • utiliz.xlsx: When trying to generate a PDF of Display sheet the first row of each row are being rendered in smaller fonts, although we have configured the sheets providing them a generic font properties. Output PDF utiliz.PNG (25.7 KB)

  • dashboard.xlsx: In Display sheet opacity is not being applied to column charts, however the opacity is correctly being rendered in the template itself. Output PDF dashboard.PNG (32.3 KB)

  • Code to pull out PDF from the workbook

      public static void generatePDF(workbook) {
    
              for (int j = 0; j < workbook.getWorksheets().getCount(); j++) {
                  workbook.getWorksheets().get(j).getShapes().updateSelectedValue()
                  if (shouldExclude(workbook.getWorksheets().get(j).getName())) {
                      workbook.getWorksheets().get(j).setVisible(false);
                  } else {
                      def ws = workbook.getWorksheets().get("Display")
                  }
              }
    
              //Perform fomula calculation
              workbook.calculateFormula();
    
              workbook.save("myresult1.pdf");
          }
    

Is there anything that is resulting in these issues or can we resolve these issues by maintaining something in the code itself ?

Thanks

@akiesh22,
Thank you for your query.
We were able to observe the issues but we need to look into them more. We have logged the issues in our database for investigation and for a fix. Once, we will have some news for you, we will update you in this topic.

This issues have been logged as

CELLSJAVA-43082 – Smaller font rendered in each first row of table
CELLSJAVA-43083 – Opacity is not being applied to column charts

@akiesh22,
This is to inform you that we have fixed your issue (logged earlier as “CELLSJAVA-43082”) now. We will soon provide you the fixed version after performing QA and incorporating other enhancements and fixes.

@akiesh22,

Please try our latest version/fix: Aspose.Cells for Java v19.12.4 (attached)

Your issue “CELLSJAVA-43082” should be fixed in it.

Let us know your feedback.
aspose-cells-19.12.4-java.zip (6.8 MB)

@akiesh22,

This is to inform you that we have fixed your issue now. We will soon provide you the fixed version after performing QA and incorporating other enhancements and fixes.

@Amjad_Sahi

We updated our Aspose library with [aspose-cells-19.12.4-java.zip] you provided and still the issue CELLSJAVA-43082 – Smaller font rendered in each first row of table is replicating. For reference I have attached the sample template file, PDF file and the screenshot, please find these zipped.

asposeIssues.zip (1.2 MB)

Would you please look into this from your end?

Thanks

@akiesh22,
I have tried to reproduce the issue using your latest sample file but could not observe difference in text size of different rows. Could you please ensure that you are using latest version and you have sent us the correct file for testing. I have hidden the unnecessary sheets and rendered the first sheet only for testing to PDF. The input and output files are attached here for your reference. You may verify that the issue is not there in the output PDF file.

If it does not fulfil yuor requirement, please share your runnable sample code, input Excel file and output PDF file again for our testing.
sample.zip (1.1 MB)

@ahsaniqbalsidiqui

Thank you for your prompt response, very much appreciated. I will get back to you with further updates.

Thanks

@akiesh22,

I checked your output PDF file and it looks like missing fonts issue on your end. Please note, Aspose.Cells requires font files (i.e., .ttf files that should be installed on the machine) for Excel to PDF or Sheet to image features. I noticed some other fonts are used for substitutions. Please make sure the following fonts (used in the workbook) should be installed on the machine first:
e.g
Lucida Sans
Tahoma
etc.

After installing the fonts, please try your scenario/case with Aspose.Cells for Java v19.12.4 and let us know your results.

@Amjad_Sahi

As you suggested we found some required fonts were not installed in our machine. We checked the template after installing the required fonts with latest aspose-cell jar file you have provided (aspose-cells-19.12.4-java.zip), we found it worked fine for our case.

Thanks for this support. And, Do you have any idea about new(19.13) release date? We are looking forward to aspose-cell new version (19.13).

@brpokharel,

Good to know that your issue is sorted out by installing the required fonts.

Also, our next official release (e.g Aspose.Cells for Java v20.1) will be published in the next week early. You will be notified once the release is published.

In the event of any further queries or issue, feel free to contact us any time, we will be happy to assist you soon.

The issues you have found earlier (filed as CELLSJAVA-43083,CELLSJAVA-43082) have been fixed in Aspose.Cells for Java v20.1. This message was posted using Bugs notification tool by ahsaniqbalsidiqui