We're sorry Aspose doesn't work properply without JavaScript enabled.

Free Support Forum - aspose.com

Issue with images in PPT to PDF convertion

Hello Aspose Slides Team,


We are using aspose.slides-15.5.1-jdk17 in the current project.

I have an application to convert from a PPT(or)PPTX to PDF. I am using the following code

Presentation pres = new Presentation(Path+ “test ppt.pptx”);
pres.save(Path+“Aspose_PptToPDF_Out.pdf”,com.aspose.slides.SaveFormat.Pdf);

I am able to convert PPT(containing images, text, etc) to PDF successfully when I run this as a simple java application.

But in our current project, we are using a Servlet to do the conversion. In this scenario only if the ppt has just plain text then the conversion is successful.

If the PPT has even a single image, it fails. The following is the error log.
java.lang.NoClassDefFoundError: Could not initialize class com.aspose.slides.acs
at com.aspose.slides.Picture.do(Unknown Source)
at com.aspose.slides.Picture.do(Unknown Source)
at com.aspose.slides.tf.do(Unknown Source)
at com.aspose.slides.tf.if(Unknown Source)
at com.aspose.slides.tf.(Unknown Source)
at com.aspose.slides.GeometryShape.do(Unknown Source)
at com.aspose.slides.GeometryShape.for(Unknown Source)
at com.aspose.slides.PictureFrame.do(Unknown Source)
at com.aspose.slides.GroupShape.do(Unknown Source)
at com.aspose.slides.Slide.do(Unknown Source)
at com.aspose.slides.Slide.do(Unknown Source)
at com.aspose.slides.axl.do(Unknown Source)
at com.aspose.slides.axl.if(Unknown Source)
at com.aspose.slides.Presentation.do(Unknown Source)
at com.aspose.slides.Presentation.save(Unknown Source)

Hi Padmaja,

I have observed the issue shared by you and request you to please share the sample presentation with us causing issue on your end. It seems to be an issue with Aspose.Slides. We will log an issue in our issue tracking system for resolution once the presentation will be shared.

Many Thanks,

Hello Team,


Please find the attached PPT that is creating the issue. If I delete slides 9, 10 in the attached PPT then the conversion happens successfully.

Hi Padmaja,

I have worked with the presentation file shared by you using Aspose.Slides for Java 15.5.1 on my end in Windows 7 x64 with JDK 1.7_65. I have not been able to observe any issue while exporting the presentation to PDF. For your kind reference, I have attached the generated PDF as well. Can you please try using the simple console based application on your end to verify if the issue happens or not.

Many Thanks,

Hello Fayyaz,


Even we were able to convert the ppt(pptx) to PDF conversion when we do the conversion using a regular java class(or) by using a servlet(Tomcat).

But, in our project we are using OSGI framework. For some reason the aspose-slides jar doesn’t work well as mentioned in the earlier comments. The conversion happens only when there are no images in the PPT.

On a completely different note, when the PPT’s are copied into a LINUX box and converted there using a regular java class or a servlet, The conversion is happening but the generated PDF is losing some formatting.


Thanks,
Brocade

Hi Brocade,


Thank you for sharing the feedback with us. I have observed the comments shared by you and have observed two issue shared by you. First is concerning to Aspose.Slides failing to export presentation with images to PDF OSGI application. I request you to please share the sample OSGI application along with steps to configure environment on my end and reproduce the issue. I also request you to please share the operating system and java details where you have tested OSGI application. Please also try using Aspose.Slides for Java 15.6.0 by creating a simple console based application in same environment where you are testing the OSGI application with same presentation having images in it. Please share these findings with us.

The second issue that you have shared is when you perform export to PDF in Linux environment, the conversion takes place but there are formatting issues. Please try using Aspose.Slides for Java 15.6.0 in your Linux box and try exporting the presentation to PDF. If there is still an issue then please share the sample presentation, generated PDF, Java and Linux details with us. I will investigate the issue further on my end to help you out.

Many Thanks,

Hello Fayyaz,


Is it possible that we have a web-ex session or team-viewer session and discuss this problem ?

Hi Brocade,

I have observed your comments and like to share that we may provide support on forum. You may also contact for quick help via live chat support as well. However Aspose does not offer support for Webex sessions or Team viewer sessions.

We are sorry for your inconvenience,