We're sorry Aspose doesn't work properply without JavaScript enabled.

Free Support Forum - aspose.com

Issues With PowerPoint Presentation Containing Media File (Video)

Hi,


I Created a PPTx which contains media file (Video file from windows sample


videos) in Office 2007 and loaded this powerpoint presentation using Aspose API and then called save on the loaded Presentation instance twice.

I am getting a ClassCastException when I try to save the Presentation instance second time. However I am not seeing such a behaviour with a simple 2007 PowerPoint presentation which does not contain media files.

The powerpoint presentation is attached with this post for your reference.

The code used is given below:

public void test2() {
Presentation ppt = new Presentation(“PPT_With_Media.pptx”);
ppt.save(“SAVE1.pptx”, SaveFormat.Pptx);
ppt.save(“SAVE2.pptx”, SaveFormat.Pptx);
}

The exception stack trace is given below:

java.lang.ClassCastException: com.aspose.slides.p883e881b.bjm cannot be cast to com.aspose.slides.p883e881b.odk
oracle.epm.platform.core.reportpackage.docman.ppt.AsposeSlidesUtilityTest.test2(AsposeSlidesUtilityTest.java:95)
sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
java.lang.reflect.Method.invoke(Method.java:606)

Hi,


Thank you for your interest in Aspose.Slides.

I have observed your comments and like to share with you that I have worked with the presentation file shared by you. I have not been able to reproduce the issue. Both the files SAVE1 ans SAVE2 are saved successfully with the media inside them, without any exception. I request you to please try using Aspose.Slides for Java 15.5.1 on your end and then share the feedback with us.

Best Regards,

Hi,


I am still seeing this issue in ASPOSE SLIDES JAVA 15.5.1.
Please let me know how this can be resolved.


I am using the same code and sample presentation with slides latest version (ASPOSE SLIDES JAVA 15.5.1).

Please note the powerpoint is created using Office 2007.


Thanks
Manisha,

Hi Manisha,


I have observed your comments and like to request you to please share with us environment details on your end. I am unable to observe the issue in window 8.1 64 bit, JDK 1.8 on my end.

Best Regards,

Hi,



Thanks for looking into this.

The environment details are given below.

Oracle Linux 5 (Intel 64-bit, Developer), JDK 1.7



Thanks
Manisha,

Hi Manisha,


Thank you for sharing the details with us.

I have worked with the presentation file shared by you. I have been able to reproduce the issue in linux on my end, A ticket with ID SLIDESJAVA-34938 has been logged into our issue management system to further investigate and resolve it. This thread has been linked with the issue so that you may be automatically notified once the issue will be resolved.

We are sorry for your inconvenience,

The issues you have found earlier (filed as SLIDESJAVA-34938) have been fixed in this update.


This message was posted using Notification2Forum from Downloads module by Aspose Notifier.