We're sorry Aspose doesn't work properply without JavaScript enabled.

Free Support Forum - aspose.com

JVM Crash with the method slide.getThumbnail()

In the last days I found an issue using the method slide.getThumbnail() for a paricolar slide.

Here below some information retrieved

Java frames: (J=compiled Java code, j=interpreted, Vv=VM code)<?xml:namespace prefix = o ns = "urn:schemas-microsoft-com:office:office" />

j sun.awt.image.ImagingLib.transformBI(Ljava/awt/image/BufferedImage;Ljava/awt/image/BufferedImage;[DI)I+0

j sun.awt.image.ImagingLib.filter(Ljava/awt/image/BufferedImageOp;Ljava/awt/image/BufferedImage;Ljava/awt/image/BufferedImageLjava/awt/image/BufferedImage;+194

j java.awt.image.AffineTransformOp.filter(Ljava/awt/image/BufferedImage;Ljava/awt/image/BufferedImageLjava/awt/image/BufferedImage;+356

j sun.java2d.pipe.DrawImage.renderImageXform(Lsun/java2d/SunGraphics2D;Ljava/awt/Image;Ljava/awt/geom/AffineTransform;IIIIILj

[Apr 8, 2010 2:29:44 PM (http-80-Processor3_370)]: generateActivitySheet # Slide Collection Found: oid=1.11.57275, CustomType=Slide Collection

This matches:

=>0x47995138 JavaThread "http-80-Processor3" daemon [_thread_in_native, id=5336]

User:

[Apr 8, 2010 2:29:40 PM (http-80-Processor3_370)]: RunScript - executing script: pscripts\PPTFactory/eBMR-splitSlides.py, threadId: http-80-Processor3, user: Lucie Benveniste-Bonald.

[Apr 8, 2010 2:29:40 PM (http-80-Processor3_370)]: RunScript - compiling script: pscripts\PPTFactory/eBMR-splitSlides.py, threadId: http-80-Processor3.

Thanks
Marco

Hi Marco,

Thanks for your interest in Aspose.Slides.

In order to add the issue issue in our tracking system, I need to verify and reproduce the issue as specified by you. For that, i need your cooperation in terms of sharing your source presentation that is raising the specified exception while generating the slide thumbnails. We really want to help you out and appreciate your cooperation in advance.

We are sorry for your inconvenience,

Hi Mudassir,

do you have any news about this issue?

Did you receive my mail?

Thanks

Marco

Hi Marco,

Thanks for sharing your presentation data.

I have worked upon your source presentation file and am able to successfully generate slide thumbnail using Aspose.Slides for Java 2.2.0. But there is some problem in generated thumbnail and i have attached that for your reference. An issue with ID 15999 has been created in our issue tracking system to resolve the issue. This thread has been associated with the issue, so that you may be automatically notified, once the issue is resolved.

We are sorry for your inconvenience,

Dear All,

I found another issue related to Java slides.

I try to convert a slides with the connector but I lose the connection.

Best Regards,
Marco

Dear Marco,

I have been able to observe the difference in rendering by comparing the two images shared by you. But in order to investigate and resolve the issue, please share the source presentation file. This will be really helpful for our development team as well in resolving the issue. We appreciate your cooperation in advance.

Thanks and Regards,

Dear Fayyaz,

attached the presentation.

Thanks in advance for your help.

Best regards,

Marco

Hi Marco,

I have worked on the presentation file shared by you. I have been successfully able to generate the slide thumbnail using Aspose.Slides for Java 2.2.0 with no rendering issue. For your kind information, I have shared the generated PNG and JPG images.

Thanks and Regards,

The issues you have found earlier (filed as SLIDESJAVA-15999) have been fixed in this update.


This message was posted using Notification2Forum from Downloads module by Aspose Notifier.