License Error with Aspose.Words for Java Beta 10.0.0

I’m getting a license error when trying to use the new beta version. Do I need a new license? if so I how do I get it?

Error message

The subscription included in this license allows free upgrades until 21 Jan 2011, but this version of the product was released on 05 Feb 2011. Please renew the subscription or use a previous version of the product.

Hello
Thanks for your request. Every Aspose license carries one-year subscription for free upgrades to new versions released during this time. If you check the expiration date of your license you will see that your license has expired. To check an expiration date of your license open the license file using notepad. You will see the following tags:

<SubscriptionExpiry>20110121</SubscriptionExpiry>

It means that you can free upgrade to version of Aspose.Words published before 01/21/2011.
As a variant, if you would like to test Aspose.Words for Java 10.0.0 beta without the evaluation version limitations, you can request a 30-day Temporary License. Please refer to:
https://purchase.aspose.com/temporary-license
Best regards,