We're sorry Aspose doesn't work properply without JavaScript enabled.

Free Support Forum - aspose.com

License Is Not Validated by the 22.9 Version of Aspose.Slides

Hello,

the license is not validated by the 22.9 version of Slides. Here is the error

*class com.aspose.slides.exceptions.InvalidOperationException: 
    License parsing error ---> java.lang.IllegalArgumentException: 
        Property 'http://javax.xml.XMLConstants/property/accessExternalDTD' is not recognized.*

I have to upgrade to version 22.6 for the license to be validated.

Thank you for your help

@Thierry_REMILI,
Thank you for contacting support.

This problem is related to xerces library version. The old version of the library does not support security properties like XMLConstants.ACCESS_EXTERNAL_DTD.

Please try using the following solution:

I excluded xercesImpl from pom.xml as instructed and it worked.
Thanks

@Thierry_REMILI,
We are glad to know that the issue has been resolved on your end. Thank you for using Aspose.Slides.