License problem.. canot find file


#1

Hello.
recently bought the Aspose.Excel.lic file and i am attempting to use the
License license = new License();
license.SetLicense(“Aspose.Excel.lic”);

but continualy get the “cannot find file Aspose.Excel.lic” file error …
I have tried to use an absolute path to the file name,as well as add the file to my c# project… but have failed to have it work properly.

The file is in the same directory as my c# application and in the same dir as the Aspose.Excell.dll file

your demos seem to make it look easy.

could you help find where im going wrong.

thank you = )


#2

Hi Chris,

What’s the name of your license file? Is it “Aspose.Excel.lic”?

Please check http://www.aspose.com/wiki/default.aspx/Aspose.Excel/LicensingComponent.html
for reference.


#3
 Hello thanks for the reply .<br /><br />when i unziped the aspose file i got from the webpage initialy the file was named  <br />Aspose[1].Excel.lic<br />after trying the  license with that file name.. and getting the file not found error <br />   License  license = New license<br />    License.SetLicense("Aspose[1].Excel.lic");<br /><br /><br />i then tried to rename the file to the way the examples and demos show it .<br /><br />   License  license = New license<br />   License.SetLicense("Aspose.Excel.lic");<br /><br />still not able to find the file... i then tried to reference the absolute file patth C:/ ..../Aspose.Excel.lic<br /><br />

#4

Please try:

1. Rename your license file name to “Aspose.Excel.lic”.

2. Put it in the same folder with your program.

3. If it still doesn’t work, please try:

License license = New license();
License.SetLicense(“C:\…\Aspose.Excel.lic”);

4. If it still doesn’t work, please try to include the license file in your project as embedded resources.

5. If still no luck, please post your license file here. I will check it.


#5

Hello again . thanks for your reply …

i still seem to have problems with the license include… so i have ziped up my working directory taht contains all my files . including my lic file … maybe you could see where im going wrong.

report start is the file that contains the reference to my lic file.

thanks again


#6

The name of your file is "Aspose.Excel.lic.xml". So please change your code to:


License license = New license();
License.SetLicense("Aspose.Excel.lic.xml");