Free Support Forum - aspose.com

Line breaks not showing correctly

When the attached Visio file is saved as SVG, the following problem occurs. Please see the attached SVG file as an example.

The line breaks in the text at the bottom of the screen are not displayed properly.

Regards,
Andrew

services bid.zip (210.3 KB)

@andrew.ridgeley,
We have tested your source VSDM drawing with the latest version 17.7 of Aspose.Diagram for .NET API and managed to replicate the issues as below:

This is the output SVG: Services Bid_17.7.zip (5.1 KB)
DIAGRAMNET-51329: VSDM to SVG - the line breaks are not preserved
DIAGRAMNET-51330: VSDM to SVG - an additional watermark text is added

We have linked your post to these tickets and will keep you informed regarding any available updates. We are sorry for the inconvenience caused.

Best Regards,
Imran Rafique

@andrew.ridgeley,
The ticket ID DIAGRAMNET-51330 has been resolved. If there is no issue in the quality assurance phase, then this fix will be included in the next version of Aspose.Diagram for .NET 17.8. We will inform you via this forum thread as soon as the new release is published.

Best Regards,
Imran Rafique

@andrew.ridgeley,
The ticket ID DIAGRAMNET-51330 has been fixed. Please download and try the new version 17.8 of Aspose.Diagram for .NET API.

Best Regards,
Imran Rafique

@andrew.ridgeley,
The ticket ID DIAGRAMNET-51329 has been resolved. If there is no issue in the quality assurance phase, then this fix will be included in the next version 17.9 of Aspose.Diagram for .NET API. We will notify you once the next version is published.

Best Regards,
Imran Rafique

@andrew.ridgeley,
In reference to the ticket ID DIAGRAMNET-51329, please download and try the latest Hotfix version: Aspose.Diagram for .NET 17.8.1

This particular issue (DIAGRAMNET-51329) is NOT fixed in this hotfix version.

Regards,
Andrew

@andrew.ridgeley,
We have reopened the linked ticket ID DIAGRAMNET-51329 in our bug tracking system. We will let you know once it is fixed.

Please can you let me know how work on this issue is progressing? It is now over a month since the ticket was logged.

Thanks,
Andrew

@andrew.ridgeley,

In reference to the linked ticket ID DIAGRAMNET-51329, we can see no line breaks in the Microsoft Visio 2016 and Aspose.Diagram API renders SVG in the same view. However, we can see line breaks in the Microsoft Visio 2013 application and require to investigate the root cause. We will let you know once it is fixed.

@andrew.ridgeley

We would like to share with you that the issue DIAGRAMNET-51329 has been fixed in Aspose.Diagram for .NET 20.5.1.

The issues you have found earlier (filed as DIAGRAMNET-51329) have been fixed in Aspose.Diagram for .NET 20.6.