We're sorry Aspose doesn't work properply without JavaScript enabled.

Free Support Forum - aspose.com

Losing part of DocumentProperty Author value

Hi Aspose team,

I am trying to change Document property text and for some reason not complete text is shown.
Please see check attached document.
Author value is: "´áb_x0003_à_x0002__x0002_" but I am getting only "´ábà".

Code is simple:

Dim PropertyName As String = ""
Dim OldProperty As String = ""

For Each prop In officeDocument.BuiltInDocumentProperties
If prop.Type = Aspose.Cells.Properties.PropertyType.String Then

PropertyName = prop.Name
OldProperty = prop.Value.ToString
end if
next

Can you please assist?

Thanks,
Oliver

Hi Oliver,


Thank you for sharing the sample spreadsheet.

We have evaluated the presented scenario while using the latest version of Aspose.Cells for .NET 8.6.0.1 and we are able to notice the problem, that is; the Aspose.Cells API reads the Author information incomplete for the given spreadsheet. We have logged this incident in our bug tracking system under the ticket CELLSNET-43928 for further investigation. Our product team will further look into the details of this problem and we will keep you updated on the status of correction.

That said, as you have mentioned that you are updating the document properties, if you are using Aspose.Cells APIs for this manipulation then please try the latest version. I have confirmed if the document property is set using Aspose.Cells for .NET 8.6.0.1 then it can be read correctly.

VB

Dim PropertyName As String = ""
Dim OldProperty As String = ""
Dim officeDocument = New Workbook()
officeDocument.BuiltInDocumentProperties.Author = "´áb_x0003_à_x0002__x0002_"
officeDocument.Save(“D:/book1.xlsx”)
officeDocument = New Workbook(“D:/book1.xlsx”)
For Each prop In officeDocument.BuiltInDocumentProperties
If prop.Type = Aspose.Cells.Properties.PropertyType.String Then
PropertyName = prop.Name
OldProperty = prop.Value.ToString
Console.WriteLine(PropertyName)
Console.WriteLine(OldProperty)
End If
Next

Hi,


Please try our latest version/fix: Aspose.Cells for .NET v8.6.0.2

We have fixed your issue now.

Let us know your feedback.

Thank you.
Hi,

worked great.

Thanks for help,
Oliver

Hi Oliver,


Thank you for the confirmation. Please feel free to contact us back in case you need our further assistance with Aspose APIs.

The issues you have found earlier (filed as CELLSNET-43928) have been fixed in this update.


This message was posted using Notification2Forum from Downloads module by Aspose Notifier.