Free Support Forum - aspose.com

MailMessage.Load performance issue in version 19.2


#1

Hi,

I have updated my Aspose Email to version 19.2 but unfortunately there is a performance issue wrt MailMessage.Load() method. This issue does not occur with older versions of aspose mail.

When the load method is called initially, it takes upto 40 sec to execute.

The code that I use to read message from eml:

EmlLoadOptions loadOptions = new EmlLoadOptions();
loadOptions.setPrefferedTextEncoding(StandardCharsets.UTF_8);
MailMessage message = MailMessage.load(eml_file, loadOptions);

Could you please look into this issue?

best regards

Arne


#2

@arne411,

Can you please share the source files, Operating system details and statistics achieved on your machine while loading eml file.


#3

Hi,

I have tested the method deeper and found that the issue is not based on the Aspose Email version.

The delay occurs when I call a cxf web service before calling the MailMessage.load() method. Earlier I used jax-ws web services and now I have migrated to apache cxf.

I need some time to investigate the issue further and provide you concrete statistics and sources.

I request you to leave the issue open until I report back to you.

best regards

Arne


#4

@arne411,

Thank you for sharing the updates.


#5

Hi,

I have made a test project with two test cases. Please find the attached sources.

Case 1: TestWithoutDelay(): This is the test that does not use any webservice.

Case 2: TestWithDelay(): This test calls a SOAP web service over apache cfx.

Both the test cases return the execution time of MailMessage.load() method. It can be seen that the test case with web service call takes around 10914 milliseconds while the other takes only 1652 milliseconds.

Could you please investigate on this issue?

AsposeMailTestwithWebService.zip (19.8 KB)

best regards

Arne


#6

@arne411,

I have observed the statistics shared by you and an issue with ID EMAILJAVA-34515 has been created in our issue tracking system to further investigate and resolve the issue. This thread has been linked with the issue so that you may be notified once the issue will be fixed.