Free Support Forum - aspose.com

Mails with mail attachment

Hi,

We are experiencing problems when uploading mails with mails attached into a Sharepoint document library.
The original (mother) mail is perfect and can be opened with Outlook. All attachments can be opened from the mail.
All attached files are extracted as separate files to the Sharepoint (2007) document library, but msg. files (children) become unreadable. Outlook (2003) returns the error: "The operation failed due to a registry or installation problem. Restart Outlook and try again. If the problem persists, please reinstall". when trying to open the file.

Any suggestions?

Thanks in advance, Inge

Hello Inge,

thank you for considering Aspose.
Could you please provide us with the details regarding product version you are using?

Hi Alex,

As far as I know it is v5.5.0.1

Inge

Hi,

Thank you for inquiry.

I would first suggest you to please try the latest version of Aspose.Network for .NET 6.8.

If you still face the issue, could you please provide some more details how you are using Aspose.Network for .NET with SharePoint? For example, according to the above post

  • "experiencing problems when uploading emails" Are these emails created with Aspose.Network?
  • “All attached files are extracted as separate files
    to the Sharepoint (2007) document library, but msg. files (children)
    become unreadable.” Do you use Aspose.Network for this as well
Any sample code, related to only Aspose.Network would be helpful for us to reproduce the issue at our end.

Thank you for your suggestions.

We will try installing the more recent version.

As to your questions. The original (mother) mail is created in any mail software and received in Outlook. Aspose.Network is used for extracting the attachments upon upload in Sharepoint. In case it is a .msg file the attachment is corrupted. If I try opening such a corrupted file in Outlook Web Access I get the error "This type of attachment must be saved to disk. [...]".

I don't know if this helps.

Inge

Hi Inge,

In that case, it seems that nested MSG attachments are not being extracted properly from the message. If the latest version also does not work then please post a sample email (the parent email with nested MSG attachments) here, we will check at our end.