We're sorry Aspose doesn't work properply without JavaScript enabled.

Free Support Forum - aspose.com

Massive increase in rendering time following upgrade to Aspose.Slides 4.8.0

We just upgraded to Aspose 4.8.0 to take care of a rectangle spanning multiple slides issue. While that issue was fixed, it appears to have brought us another issue:
It used to take < 30 seconds to render our reports to PPTX. Now we’re seeing 4-8 minutes elapse before the prompt to open/save appears.

I have reverted back to our previous version (Aspose.Slides 4.7.0) and it renders in about 30 seconds. We’re running SQL Server 2008 R2.

Thank you,
Josh

Hi Josh,


I have observed the performance issue shared by you while using the latest version. Can you please share the RPL file with us by exporting reports from both versions. Please also share the RDL file by using Adventure Works as data source. Please share the machine and environment details that you have on your end to verify the performance. I will generate a ticket for this in our issue tracking system based on availability of requested information to carry out investigation.

Many Thanks,

Mudassir,
Thank you for taking a look at this. It doesn’t seem to matter which report we try to render in PPTX, so I’m just attaching the same rdl we used for the original issue. I’ve included the RPL export from both 4.8.0 and 4.7.0. Datasource is Adventureworks 2008.

The two servers we have tested on both have the following specs


Proc; Intel Xeon CPU E5-2680 @2.70 GHz
RAM 16 GB
Windows Server 2008 R2
- Running SQL Server 2008 R2

I hope this helps. We have backed out of our Aspose upgrade, and are waiting on this issue before we can declare the other issue (rectangles spanning multiple pages) resolved.

Regards,
Josh

Hi Josh,


Thanks for sharing the information and details. I have created an issue with ID SLIDESREP-33282 in our issue tracking system to further investigate and resolve the issue. This thread has been linked with the issue so that you may be automatically notified once the issue will be addressed and resolved by our development team.

We are sorry for your inconvenience,

Hi Mudassir,
Any update on this performance issue?

Regards,
Josh

Hi Josh,


I have verified from our issue tracking system and regret to share that the issue has not yet been scheduled for investigation. I have requested our development team to kindly schedule the issue and share the feedback. I will share the feedback with you as soon as it will be shared by our development team.

Many Thanks,

Mudassir,
Please get back to us with an ETA on this issue. We are unable to upgrade to the current version (and the fixes to the rectangle layout issue we reported 3 months ago) until we can get past the debilitating performance issue.

Also, if this is not being prioritized (which would be odd, since the latest release of this product is essentially unusable until this is resolved), please let me know so that I can escalate the issue on our side.

Regards,
Josh

Hi Josh,


We are sorry for your inconvenience. The issue shared has been scheduled for investigation during Week 26/2013. Once the investigation will be completed, we will be able to share the further feedback with you in this regard. I have requested our development team to share their findings in this regard as well. In order to further expedite the issue resolution, I may suggest you to please consider our priority or enterprise support options. Please visit this web link for your kind reference. You can consult our Sales team in Aspose.Purchase forum for availing the priority or enterprise support options in order to escalate the issue.

Many Thanks,

Mudassir,
Thanks for the date information. End of June should be fine. Thanks!

Hi Mudassir,
Any update on this issue?

Regards,
Josh

Hi Josh,


I have verified from our development team and regret to share that the issue shared is not yet resolved. The issue is complex and is needed to be addressed in Aspose.Slides for .NET first as Aspose.Slides for Reporting Services internally uses Aspose.Slides for rendering. Once the issue will be fixed in Aspose.Slides for .NET, it will then be resolved for Aspose.Slides for Reporting Services. We are working over your issue and will appreciate your feedback in this regard.

Many Thanks,

Hi Mudassir,
Happy August. What’s our ETA?

Hi Josh,

I like to share that the issue blocking SLIDESREP-33282 has been resolved in Aspose.Slides for .NET 7.7.0 today. Now, our development team will focus on fixing the said issue. I have requested then to kindly share the ETA and will share the same with you as soon as it will be shared by them.

Many Thanks,

The issues you have found earlier (filed as SLIDESREP-33282) have been fixed in this update.


This message was posted using Notification2Forum from Downloads module by Aspose Notifier.