We're sorry Aspose doesn't work properply without JavaScript enabled.

Free Support Forum - aspose.com

Memory bloat- never returning on opening worksheet

I am having a problem where I am trying to open an Excel workbook with a line of code that looks like this:


var workbook = new Workbook(inputFileInfo.FullName);

I am using Aspose.Cells for .NET 8.3.0.0.

The problem is that when I try and run that line in both .NET and mono, it never returns and my .NET process uses over 15GB of memory. It is a 2MB .xlsx file that I can’t post here because it contains sensitive client information, but I can e-mail you separately if you would like.

Thank you for your help.

Hi William,


Thank you for contacting Aspose support.

Please try loading your spreadsheet as follow while using the latest version of Aspose.Cells for .NET 8.3.1.

C#

LoadOptions options = new LoadOptions();
options.MemorySetting = MemorySetting.MemoryPreference;
Workbook book = new Workbook(filename, options);

In case the problem persists, please provide us your sample spreadsheet for further investigation.

Thank you for the suggestion, but it did not fix the problem. I have sent the workbook to your e-mail address. Please let me know whether or not you have received it.

Hi Bill,


Thank you for sharing the sample spreadsheet via an email. I am currently evaluating your presented scenario, and I will shortly update you in this regard.

Hi again,


I have tested the case against the latest version of Aspose.Cells for .NET 8.3.1, and I am able to replicate the said problem. The process of loading the given spreadsheet into an instance of Workbook consumes almost 90% of the system memory thus making the system unresponsive. I have logged the problem in our bug tracking system under the ticket CELLSNET-43236 for further investigation. Please spare us little time to properly analyze the problem cause, and to provide the fix at earliest possible. In the meanwhile, we will keep you posted with updates in this regard.

Hi Bill,


This is to inform you that we have fixed the issue logged earlier as CELLSNET-43236 in our bug tracking system. We will shortly provide the fix for your testing after performing QA over it. As soon as the fix is ready for public use, we will notify you here with the download link to the upgraded API.

Thank you for your patience with us.

Hi,


Please try our latest version/fix: Aspose.Cells for .NET v8.3.1.1

We have fixed your issue now.

Let us know your feedback.

Thank you.

Thank you, this seems to be working for us.

Hi Bill,


Thank you for the confirmation. Please feel free to contact us back in case you need our further assistance with Aspose APIs.

The issues you have found earlier (filed as CELLSNET-43236) have been fixed in this update.


This message was posted using Notification2Forum from Downloads module by Aspose Notifier.