Free Support Forum - aspose.com

Menu appears on the page- not on a popup!

Hi!

I'm using a registered web grid v1.9.3.0.

When I load my page, a menu (I think it's the grid popup menu!), appears on the page, please take a look at the attached file.

How do get rid of this? I've tryied already to change the web.config file with

<appSettings>

<add key="aspose.grid.web.agw_client_path" value="/agw_client/" />

<add key="aspose.grid.web.force_script_path" value="true" />

</appSettings>

But it still doesn't work...

António Carvalho

Hi Carvalho,

Do you right click on the control area to show the popup menu or the menu is just appeared automatically and the menu is completely shown or some of the options are displayed. Could you give us some details, sample code work or property settings especially related context menu, OS, .NET framework, Browser Type, MS Ajax Extensions yes/no, IIS settings etc.

Thank you.

Hello Amjad,





The menu that I show in the image, is displayed automatically… I don’t need to click the grid or else where.

But when, I click in the grid, the menu disapeares from the top, and appears after the grid in the page.



I don’t know if this can help as I’ve forgot to mention: the grid is inside a MS Ajax update panel.



Regards,

António Carvalho

Hi Carvalho,

Thanks for considering Aspose.

Please check in Html source page:

If your is like , then you should set GridWeb 's .XHtmlMode to false

And if is like.... <!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN"....., you should set GridWeb 's .XHtmlMode to true.

Please try this.

Thank you.