We're sorry Aspose doesn't work properply without JavaScript enabled.

Free Support Forum - aspose.com

Message body- when saved to msg file- is incorrect

when using windows 2003 server as the operating system host, the body of the message, when saved to msg format, is literally:


Hello,

This is a test.

-kyle


the code used to do this is:

public void saveMessage(ExchangeMessageInfo message, string filePath)
{
MailMessage msg = client_aspose.FetchMessage(message.UniqueUri);
msg.Save(filePath, MessageFormat.Msg);
}

this bug is isolated to windows 2003 server

the assembly we are using is: 5.4.0.4 "hotfix"

i did see http://www.aspose.com/community/forums/227714/aspose.network-v5.0.0-convert-mailmessage-to-mapimessage-rtf-problem/showthread.aspx#227714

but reverting to such an old version (the 5.0.0.1 attachment in that thread) is out of the question at this point since there were some really flaky bugs resolved in the “hotfix” we are using.

Hi,


Could you please try v5.5 of Aspose.Network for .NET and check if this message still comes in the saved MSG file?

If yes, could you please provide the following details:
  • Exchange Server version
  • Environment of the program using Aspose.Network
    • OS version (x86/x64)
    • .NET version
    • ExchangeClient or ExchangeWebServiceClient class
I checked at my end with ExchangeWebServiceClient class, but could not reproduce the issue with Aspose.Network for .NET v5.5.

Exchange Server version is Exchange 2007

The OS version is x86. The problem only happens on x86 machines, the problem does not happen on x64 machines.

.Net 3.5

WebServices DLL version 14.0.650.7

Thanks,

Chad