We're sorry Aspose doesn't work properply without JavaScript enabled.

Free Support Forum - aspose.com

Message content formated incorectly with BodyRtf

Hello,

I have a strange issue with Network.Outlook.MapiMessage.FromFile. When you give it an msg file which was sent from a web client and has very simple content formatting (like this: asafa



fgdgd



qszxcc
)
With the help of BodyRtf it gets content as simple text without any formatting. Simmilar issue I have seen in a few emails which were sent from MS Outlook 2007. Is there any fix/workaround to get correctly formatted rtf content at least for outlook 2007?

Regards,
Edvardas


Hi Edvardas,

Thanks for considering Aspose.

Could you please post some sample msg files here for our testing.

Please find msg examples attached.

Hi Edvardas,

I was able to reproduce this bug and I have logged it in our issue tracking system (ID: 13075) and notified the developers about this issue.

We will notify you here once it is resolved. Sorry for the inconvenience.

The issues you have found earlier (filed as 13075) have been fixed in [this update ](http://www.aspose.com/community/files/51/.net-components/aspose.network-for-.net/entry229369.aspx).

This message was posted using Notification2Forum from Downloads module by aspose.notifier.

Hi,

We did some investigation on this issue. If you send email from a web client in html format and receive it in Outlook, the Outlook converts the html to rtf format. This converted rtf is not regular rtf format. It is extended rtf format described in RTF Extensions Specifications. It is only supported in Microsoft Outlook. And if you save the rtf body to an rtf file, it is displayed incorrectly.

As an alternate solution, could you please use MailMessage class to get the Html body of those emails which were sent via any web client or outlook.

For receiving regular rtf, if you choose “options” --> “Rich text” from outlook and send email, the MapiMessage.BodyRtf will have the regular rtf format. And if you save it to an rtf file, it will be displayed correctly.