Free Support Forum - aspose.com

Method WriteAsSvg terminates linux docker container when invoked a second time for the same slide (.NET Core Linux)

When invoking WriteAsSvg the first time, it takes 56 seconds to render create the SVG of the slide. On the second invocation, the SVG does not get created and the linux container stops. Below is the output. I have also include a link to a sample where this occurs. You will need to access the link so I can give you access.
Sample code link: https://drive.google.com/file/d/1U6Tag7c5v9bKFFXQT9LzXRTemD9Qag2T/view?usp=sharing

Loaded ‘/usr/share/dotnet/shared/Microsoft.NETCore.App/3.1.0/System.ComponentModel.Primitives.dll’. Skipped loading symbols. Module is optimized and the debugger option ‘Just My Code’ is enabled.
7224160
Before slide /tmp/tmplAVhrd.tmp 0
Loaded ‘/usr/share/dotnet/shared/Microsoft.NETCore.App/3.1.0/System.Reflection.Emit.ILGeneration.dll’. Skipped loading symbols. Module is optimized and the debugger option ‘Just My Code’ is enabled.
Loaded ‘/usr/share/dotnet/shared/Microsoft.NETCore.App/3.1.0/System.Reflection.Emit.Lightweight.dll’. Skipped loading symbols. Module is optimized and the debugger option ‘Just My Code’ is enabled.
Loaded ‘/usr/share/dotnet/shared/Microsoft.NETCore.App/3.1.0/System.Reflection.Primitives.dll’. Skipped loading symbols. Module is optimized and the debugger option ‘Just My Code’ is enabled.
Loaded ‘/usr/share/dotnet/shared/Microsoft.NETCore.App/3.1.0/System.Security.Cryptography.Csp.dll’. Skipped loading symbols. Module is optimized and the debugger option ‘Just My Code’ is enabled.
Loaded ‘/usr/share/dotnet/shared/Microsoft.NETCore.App/3.1.0/System.Security.Cryptography.Primitives.dll’. Skipped loading symbols. Module is optimized and the debugger option ‘Just My Code’ is enabled.
Loaded ‘/usr/share/dotnet/shared/Microsoft.NETCore.App/3.1.0/System.Core.dll’. Skipped loading symbols. Module is optimized and the debugger option ‘Just My Code’ is enabled.
Loaded ‘/usr/share/dotnet/shared/Microsoft.NETCore.App/3.1.0/System.Linq.dll’. Skipped loading symbols. Module is optimized and the debugger option ‘Just My Code’ is enabled.
Loaded ‘/usr/share/dotnet/shared/Microsoft.NETCore.App/3.1.0/System.Buffers.dll’. Skipped loading symbols. Module is optimized and the debugger option ‘Just My Code’ is enabled.
Loaded ‘/usr/share/dotnet/shared/Microsoft.NETCore.App/3.1.0/System.Resources.ResourceManager.dll’. Skipped loading symbols. Module is optimized and the debugger option ‘Just My Code’ is enabled.
After slide /tmp/tmplAVhrd.tmp 0
13176280
WriteAsSVG took 56033 milliseconds
6749760
Converted successfully…!
15958888
Before slide /tmp/tmpdQrjIl.tmp 0
The program ‘dotnet’ has exited with code 0 (0x0).

Randy

@clarksrjey,

I have observed the issue shared by you and request you to please share the working sample project reproducing the issue. I also suggest you to please first try using latest Aspose.Slides for .NET 19.12 on your end as well.

The sample is located in the previous post. I have specified it again below. You will need to click on the link so I can give you access.

@clarksrjey,

I have tried accessing the google drive on and it is asking for giving rights. I have requested for grant of rights. Please provide that.

Yes. As I mentioned above. You had to click on the link for me to give you rights. You should have rights now. Let me know if there are any issues accessing it.

@clarksrjey,

Thank you for sharing the details with us. An issue with ID SLIDESNET-41683 has been created in our issue tracking system to further investigate and resolve the issue. This thread has been linked with the issue so that you may be notified once the issue will be fixed.