Free Support Forum - aspose.com

Msg file sender address incorrect format

Hi,


I raised an issue a while ago about the email sender address format:
Msg file sender address is invalid in outlook

This was marked as fixed under the Aspose.Email for Java 1.7.0 release in the release notes enhancement number NETWRKJAVA-33131.

I have just tested this with the latest version of the library 2.8.0 and found that the problem is still there.
I have attached the sample file used for testing.

Here is the code that was used for testing:

MapiMessage origMessage = MapiMessage.fromFile(“C:\temp\testupload.msg”);
System.out.println (origMessage.getSenderEmailAddress());

The output of the sender address above is still in the format of </O=TEST/OU=TEST1/CN=RECIPIENTS/CN=TEST>.

Please let me know if this is still a bug.

regards & thanks!

Hi Chamindu,


Thanks for writing to Aspose.Email support team.

I have analyzed the attached message with both the versions i.e. Aspose.Email for Java 2.8.0 and 1.7.0. Both the times I got the same string as given below:
/O=MBL/OU=MBL1/CN=RECIPIENTS/CN=CHATHTHO

Could you please verify if you are getting the same string while using above mentioned versions.

I also analyzed the MSG file using OutlookSpy and observed the properties. It is noted that SMPT format address is missing and we found the exchange format address in the message properties. This is the reason why Aspose.Email cannot display it in SMTP format.

Please let us know your feedback for further assistance.

Hi,


Yes I’m getting the same string.
I was hoping to get the name@domain.com format instead of the Exchange format.

Do you know if there is a setting on Exchange to enable this?
Or any other workaround?


regards
CH


Hi Chamindu,


Thanks for the feedback.

The Exchange format email address is a well-known issue for Microsoft Outlook and one of the possible reasons could be improper Exchange configuration. Unfortunately, there is no work around method as Aspose.Email can not retrieve some information that isn’t available in a message file. Additionally, I don’t have any such information about fixing it as it is related to configuration of Exchange server, and appreciate your understanding in this regard.