Free Support Forum - aspose.com

New developer grid not working

Hi All,

I have recently taken over a project using WebGrid.

I am migrating part of the site to another project and when using the grid it is not displaying properly.

I have tried the most simple implimentation of just putting the grid on the page and also copied the html source form a working page in another project.

The grid shows as a simple grid, but it does not accept a click or show any changes to the design, such as adding a column or command button.

The grid was already installed and set up on the previous project so I am not sure what I need to do to correct this.

I have applied the licence in the Global.asax.

Any assistance would be appreciated

The command buttons are showing now, but still not clickable and my bound column doesn't show.

I cant edit any cell.

PS. I have wired the events for the command button and the submit button. But no postback

Hi,

Please tell us the envrionment, Control's version, IIS version, framework version. And we also want to see your source code.

Hi Henry,

Thanks for the response, I found the issue, there was a couple of entries in the web.config I hadn't seen in the previous developers project.

I have put those in and all seems fine.

I didn't see them in your doco, so hadn't looked too hard in that direction.

Thanks again

Rod

Hi Rod,

I am getting the same issues as you went through, can you please tell me how you resolved em

Thanks

Ben

Hi Ben,

Do you use VS.NET 2008. Please check your web project type and be sure to use HTTP mode. That means the web grid will run only with an IIS server. It does not support File Mode web site for VS.NET 2008 projects.

Thank you.

For me the following additions to the web config fixed my problems.

<appSettings>

<add key="aspose.grid.web.agw_client_path" value="http://localhost:4772/agw_client/"/>

<add key="aspose.grid.web.force_script_path" value="true"/>

</appSettings>