We're sorry Aspose doesn't work properply without JavaScript enabled.

Free Support Forum - aspose.com

No borders and background filling in cells after conversion to PDF

After conversion to PDF using Aspose.Cells 5.1.3 some cells lose borders and background filling.
Attached source Xlsx file, result Pdf file and expected Pdf file created by Excel 2010.

Please take a look.

Best regards,
Alex.

Hi,

Thanks for providing us the template files.

I have found the issue as you have mentioned. I have logged your issue into our issue tracking system with an id: CELLSNET-20585. We will figure it out soon.
thank you.

Hi, guys!
Thank you for resolving other issues. Could you give ETA for this issue?

Best regards,
Alex.

Hi Alex,

We will check if we can provide an eta for your issue soon.

Thank you.

Hi, guys!

We very appreciate your effort on resolving different issues. Could you take a look on this one? We really need it :slight_smile:

Thanks,
Alex.

Hi Alex,

We are working on this issue. We will update you soon. In the mean while could you please give following version a try. It is version v5.1.4:
http://www.aspose.com/community/files/51/.net-components/aspose.cells-for-.net/entry265124.aspx

Thanks,

I tried conversion today with Aspose.Cells 5.1.4.0. Result is attached. Unfortunately, there is no visual changes regarding this issue.

Hi,

Well, your issue relates to List (Table) style, so it cannot be supported very soon. We are working on it and hopefully before the end of next month the feature would be included.

Thanks for your understanding!

Guys,

I have prepared new source xlsx file by copy-pasting parts from the first file. The files are almost the same. However, the new one can be converted to pdf without any visual defects.
The question is what is the difference between the xlsx files? What should we avoid to use in source xlsx files?

Please advise.
Thank you,
Alex.

Hi,

Well, your sample Excel file has normal style applied, which is supported by Aspose.Cells, so it is converted to PDF file fine. I am afraid, no other MS Excel 2007 styles are supported currently, we are working on MS Excel Table Styles already. Once we have any update about it, we will let you know.

Thanks, and sorry for any inconvenience caused!

Hi,

Please try the attached version and let us know if it works fine regarding your issue.

Thanks.

Hi! Thank you for trying to solve this issue.

I have run the test again with new dll. The result has differences comparing with previous version, but I wouldn’t say it is perfect.

Please find result pdf in attachment.

Best regards,
Alex.

Hi,

This is my result which seems to me fine.

Could you check to open my resultant PDF file.

Please make sure that you are using latest version/fix v5.2.2.2.

thank you.

Yes, your result file is much better.
I checked version of Aspose - it is 5.2.2.2 (2010-01-28). But result files are still different…

Hi,

It looks very strange that you are not getting good results whereas I can get fine results (as shown by my attached PDF file).

By the way the version v5.2.2.2 is released on January 28, 2011.

Thank you.

Yes, sure - 2011.
I’ve run the same app on another machine - and it works fine. The result file is identical with yours. Thank you!

So I have one question: how it is possible to have different behaviors of Aspose.Cells on different machines?

Please note, that this is not the first time (Truncated text in some cells after conversion to PDF). I checked that Aspose.Cells is not installed in GAC.

Best regards,
Alex.

Hi,

The product’s same version should show similar behaviour on different machines in most cases.
Well, in the latest version v5.2.2, if you could install it using its MSI installer the Aspose.Cells.dll assembly does get registered in the GAC:
http://www.aspose.com/community/files/51/.net-components/aspose.cells-for-.net/entry280123.aspx

After installing the product, you may check your registration table, if it contains: e.g HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft.NETFramework\AssemblyFolders\Aspose.Cells.net2.0 etc. that will confirm that the product is registered in GAC correctly.

Thank you.

The issues you have found earlier (filed as 20585) have been fixed in this update.


This message was posted using Notification2Forum from Downloads module by aspose.notifier.