Not able to read/open workbook which contains chart

@Amjad_Sahi & @leoluo ,
Any finding here?


We are struggling with registering the account. We have been tracking your problem for a few days and we are currently stuck on the registered account. We might take more time to study it and get over with it.

Once we have an update on it, we will let you know.

Hi @Coder365
I refer to the code in the post and attach a picture, in this picture I fill 1,2,3,4 in my account info, into the code params 1,2,3,4. But I get the response:
StatusCode: BadRequest, Content-Type: application/json; charset=utf-8, Content-Length: 485)

Please check my picture, did I fill wrong info into the code? And in my code, param 5 is “Sign in to your account”, is it wrong? How should I fill param 5?

20230103.png (183.1 KB)

Hi @leoluo,

Please use below link for detailed explanation.


Thanks for sharing the video on how to get access token to call Azure Graph API with Postman. This might help. We have now logged an investigation ticket (including all the details and sample files) with an id “CELLSNET-52519” for your issue. We will into the details on the issue regarding read charts from Excel file worksheet (generated by Aspose.Cells) through Microsoft Graph API.

Once we have an update on it, we will let you know.

Thanks for such a great efforts @Amjad_Sahi & @leoluo.
Waiting for your positive response.


We will keep you posted with updates once available on it.

Hi @Coder365
We make some progress and get the access token, but I still get the fail message:
{StatusCode: 400, ReasonPhrase: ‘Bad Request’, Version: 1.1, Content: System.Net.Http.StreamContent, Headers:

Compare to the old fail before:
{StatusCode: 401, ReasonPhrase: ‘Unauthorized’, Version: 1.1, Content: System.Net.Http.StreamContent, Headers:

I think I still get something wrong in the test project, perhaps about the wrong URL or folder:
var t = client.PutAsync("" + fileName + “:/content”, obj);

In this code line, Is this URL or folder correct? Do I need any step to create the Temp_Folder first?
Now the access token is got, but update file still failed.

For more work, I created a new xlsx file by aspose.cells test version(in zip followed), please check if it works in Microsoft Graph API. (114.1 KB)

Please also try to save the original test file with Excel, and test the saved file, thanks.

Hi @Coder365
We are continuously trying to fix the problem, please use this new file, it is saved by opening your test file and saving with aspose.cells test version. you can upload it and try to call it in Microsoft Graph APIs . But don’t use your aspose.cells version open and save it, the old version of aspose.cells could cause problems with saving it. (38.3 KB)

sure @leoluo. give me sometime. I will let you know.


Sure, please take your time to evaluate the new file to test in your scenario/case. Hopefully, it will work.

Hey @Amjad_Sahi and @leoluo,

Its working fine now. Now I am getting two different graph from graph Api.
Please let me know what steps I have to perform further so that I can use this cells version.

Can you just share the details when this issue will be fixed and release?
Any estimated time?
As we are planning to purchase new aspose cells license.


Thanks for your feedback.

It is nice to know that it is working fine.

Hopefully we will include the fix in our upcoming release in our upcoming release (Aspose.Cells v23.2) which is scheduled in the first half of February 2023. You will be notified once the supported version is published.

The issues you have found earlier (filed as CELLSNET-52519) have been fixed in this update. This message was posted using Bugs notification tool by johnson.shi