We're sorry Aspose doesn't work properply without JavaScript enabled.

Free Support Forum - aspose.com

NullPointerException when saving file as text

Running this code with Aspose.Cells 8.2.1

Workbook workbook = new Workbook(inputPathname);
workbook.save(output, com.aspose.cells.SaveFormat.TAB_DELIMITED);

with the attached file results in a NullPointerException. Here's the backtrace:

at com.aspose.cells.abz.b(Unknown Source)
at com.aspose.cells.abz.a(Unknown Source)
at com.aspose.cells.acx.l(Unknown Source)
at com.aspose.cells.acx.a(Unknown Source)
at com.aspose.cells.acw.a(Unknown Source)
at com.aspose.cells.Workbook.a(Unknown Source)
at com.aspose.cells.Workbook.a(Unknown Source)
at com.aspose.cells.Workbook.(Unknown Source)



Hi Ben,

Thank you for contacting Aspose support.

Please try the case with latest version of Aspose.Cells for Java on our end. We have tested and didn’t find any problem,


I’ve tried this with version 8.3.1 (later than the you tried) and it still results in a NullPointerException. Could you have a look again?



Hi Ben,

I am afraid, I am still unable to replicate the said exception on my end while using the latest version of Aspose.Cells for Java 8.3.1 and compiling against JRE 7 & 8. In order to investigate the matter further, please provide the envirnoment details as follow.

  • Operating System version
  • Operating System Architecture (32bit/64bit)
  • JDK Type (Open/Sun)
  • JDK Version

In addition to above, please execute the following statements in same application that throws the said exception to print Java & Aspose.Cells API version.

System.out.println(System.getProperty("java.version")); System.out.println(CellsHelper.getVersion());