We're sorry Aspose doesn't work properply without JavaScript enabled.

Free Support Forum - aspose.com

ODS to XLSX - arrow shapes become rectangles

Using aspose-cells-18.11 JDK to convert ODS to XLSX.
Converting spreadsheet with arrow shape graphics. These become rectangles.

Code below:
LoadOptions loadOptions = new LoadOptions(FileFormatType.ODS);
Workbook workbook = new Workbook(inputPath,loadOptions);
workbook.save(outputPath, SaveFormat.XLSX);

Before/after sample attached

Missing arrows.zip (1.9 MB)

@simon.wiseman,

Thanks for the template ODS file and output XLSX file.

After an initial test, I am able to observe/confirm the issue as you mentioned by converting your template ODS file to XLSX file format. I have logged a ticket with an id “CELLSJAVA-42792” for your issue. The ticket is logged as following:
CELLSJAVA-42792 - ODS to XLSX - arrow shapes become rectangles

We will look into it soon.

Once we have an update on it, we will let you know.

@simon.wiseman,

I am afraid, we do no support reading custom shapes in ODS file format for now. We will look into it later on and may support it in future versions.

Thanks for looking at that.

After looking back on this case, I have converted the original MissingArrows.ods to an XLSX again using “aspose-cells-19.10.jar”.
The XLSX now has the correct arrow types, however they aren’t in the correct position on the page (see attached file to compare the ODS and XLSX).
I used ‘OpenOffice Calc’ to open the ODS file and ‘Microsoft Office Excel 2019’ to open the XLSX file.

So overall the arrows have been fixed but they aren’t in the correct position.

Using this code:
com.aspose.cells.LoadOptions loadOptions = new com.aspose.cells.LoadOptions(com.aspose.cells.FileFormatType.ODS);
com.aspose.cells.Workbook workbook = new com.aspose.cells.Workbook(inputPath,loadOptions);
workbook.save(outputPath, com.aspose.cells.SaveFormat.XLSX);

CELLSJAVA-42792.zip (1.9 MB)

@simon.wiseman,

Thanks for the ODS file and output XLSX file.

I confirmed the shapes are rendered but shapes’ position is not correct. I have logged your recent findings against your existing issue “CELLSJAVA-42792” into our database.
The issue is still Open and once we have an update on it, we will let you know here.

Thats great, thank you.

@simon.wiseman,
You are welcome.

Has there been an update regarding this issue?
I have re-tried it and I still get the same issue, using “aspose-cells-20.1.jar”.
See attached screenshot to see the existing issue.
Thanks.
arrows.PNG (47.1 KB)

@simon.wiseman,

Thanks for the screenshot.

I am afraid, the issue is still not resolved and is “Open”. I have logged your concerns with your screenshot against your issue “CELLSJAVA-42792”. We will check and may provide you an ETA on it.

That’s great thank you for the quick response.