Free Support Forum - aspose.com

Oledb objects becomes picture when excel copy

Hi team, we are using your Aspose.Cells product for excel operation, While copying one workbook sheet to another workbook, some times oledb objects become pictures. Can you please provide quick solution for this bug.

@sreelink,

Thanks for the details.

Could you provide us your template files and sample code (runnable) to reproduce the issue, we will check it soon.

Thank you Amjad for quick reply. I am sharing sample solution which also have excel files in DownloadedExcels folder. If you click on button on test.aspx page, 1st sheet of sourcesheet should be copied to destination 1st sheet, but 10 sheet object should not become pictures. While copying one sheet , other sheet documents become pictures, this issue is happening in consistently. Please let me know reasons for this issue, which cases it may happen and how to avoid this.
https://drive.google.com/file/d/1h6zY82mkZUVjSm6cmuTn7dw6v1GFaYfK/view?usp=sharing

@sreelink ,

Thanks for the sample project.

We will check your issue using your sample and get back to you soon.

Okay, fine Amjad, as this is production, request you to look into it asap. I have another doubt, is Aspose.cells will support Excel Office 365 ?

@sreelink,

After an initial test, I am able to reproduce the issue as you mentioned by using your sample project with your template files. I found Ole objects have become pictures in the output file when copying worksheets. I have logged a ticket with an id “CELLSNET-46949” for your issue. We will look into it to figure it out soon.

Once we have an update on it, we will let you know.

PS. Aspose.Cells does support Excel 365. If you find any issue, kindly do create a separate thread with all the details and samples, we will check it soon.

Amjad, can I expect resolution today, it is effecting business activities.

@sreelink,

We are very sorry but we need a little time (3-5 days or so) to evaluate your issue thoroughly. If the issue is not complex, we can fix it within a week or even before that.

Hopefully we will figure out your issue soon.

@sreelink,
This is to inform you that we have fixed your issue (logged earlier as “CELLSNET-46949”) now. We will soon provide you the fixed version after performing QA and incorporating other enhancements and fixes.

Thank you team, its good news, awaiting your new fixed version

@sreelink,
You are welcome.

team, when can i expect new version, can you please provide some tentative date

@sreelink,
Please try our latest version/fix: Aspose.Cells for .NET v19.9.4:

Aspose.Cells19.9.4 For .Net2_AuthenticodeSigned.Zip (4.9 MB)
Aspose.Cells19.9.4 For .Net4.0.Zip (5.0 MB)

Your issue should be fixed in it.

@Team,
we are using .Net 4.5 so can i use ’ Aspose.Cells19.9.4 For .Net4.0.Zip’ or do need to configure both dlls?

@sreelink,

Please use Aspose.Cells19.9.4 For .Net4.0 Dll for .NET framework versions >= 4.0, 4.5, 4.6.x or greater versions.

@Team,

Issue is not resolved, its failing with other documents merge. PFA.
Test Files.zip (2.5 MB)

@sreelink,

Thanks for the sample files.

Could you share a sample project (as you previously shared for previous issue) to reproduce the issue, we will check it soon.

@Amjad_Sahi

You can download my latest solution from below link. When i copy 10 sheet to 10 sheet 11 sheet document becomes image. Its happening inconsistently please evaluate the root cause of this issue.

https://drive.google.com/open?id=1Tetnz1a77lH-kT1Xw4LJbQTlNB5Bg33J

@sreelink,
Thank you for the sample project. We were able to observe this issue with the provided sample files and have recorded this information in the database for our reference. We will analyse the issue again and share the feedback at the earliest.

@sreelink,

This is to inform you that we have fixed your issue precisely (logged earlier as “CELLSNET-46949”) now. We will provide you the fixed version in the next week after performing QA and incorporating other enhancements and fixes.