Free Support Forum - aspose.com

Opacity doesn't set in StampAnnotation


#1

Hello. I have a problem with StampAnnotation. I set the Image property to it. Then I set the opacity, but it has no effect. I use the Opacity property. When I open the result document it has an opacity value, but the stamp is not transparent. If I don’t set the image it works fine. Please, help me. I am not sending the example, because it is easy to check.


#2

@VladimirFedorchenko

Thank you for contacting support.

Please note that we can create code snippets to check your scenario but requesting you for the code is efficient approach for assistance. It helps us understand your situation with zero differences. Therefore, please always elaborate the issues with the help of your code.

Moreover, please try Adding Image Stamp in PDF File instead of StampAnnotation, then set the opacity and share your kind feedback with us.

We hope this will be helpful. Please feel free to contact us if you need any further assistance.


#3

Thank you for your answer, but I want to use a StampAnnotation, because I need to add comments to it. Can I add comments to an Image Stamp?


#4

Is it a bug that StampAnnotation can’t set the opacity of the image?


#5

@VladimirFedorchenko

Would you please elaborate how are you adding comments to StampAnnotation so that we may investigate accordingly for ImageStamp. Moreover, also share the code snippet which reproduces problem with opcaity image so that we may identify if it is expected behavior or a problem.

Furthermore, you may Add Annotation in existing PDF file if you want to add comments on a PDF page.