Free Support Forum - aspose.com

Optional/soft hyphernation

Hi!

I´m evaluating Aspose.Words and I´m having a simular problem as this one:
<A href="https://forum.aspose.com/t/98259</FONT></A></P> <P><FONT size=2 face=Arial>I load a MS Word document into Aspose.Words and save it as PDF. Instead of hyphernation, i get the "square" sign (char 31). The pdf rendering doesn´t seem to recognize the optional hyphernation character.

Also, hidden text in the word document messes up the layout. I´m testing a workaround for that by simply replacing the hidden text with " ". Seems to work. I tried to delete the whole paragraph with hidden text, but that did not help.

Aspose.Words V 8.0.0.0 2009-11-12
.NET 2.0
Win XP SP2

Thanx in advance
Mathias

Hi<?xml:namespace prefix = o ns = "urn:schemas-microsoft-com:office:office" />

Thanks for your request. Could you please attach the FuturaMedium font here for testing? I will check the issue on my side and provide you more information.

Best regards,

Hi

<?xml:namespace prefix = o ns = "urn:schemas-microsoft-com:office:office" />

Thanks you for additional information. I managed to reproduce the problem on my side. Your request has been linked to the appropriate issue. You will be notified as soon as it is resolved. Regarding the problem, if you open/save your document using MS Word and then convert to PDF the problem disappears.

Best regards,

Thank you.

I opend the document in Word 2003 (sp3), made a small change and saved it. I still get the same result.

Hi

<?xml:namespace prefix = o ns = "urn:schemas-microsoft-com:office:office" />

Thank you for additional information. I tried to open, make small changes and save your document using MS Word 2007, MS Word 2003, MS Word 2003 SP3 and then convert to PDF. All these scenarios work without any problems. I sent the document saved using MS Word 2003 SP3 to your e-mail.

Best regards,

I first opend and saved your file as pdf. The layout was still messed up and the soft linebreaks is gone (or ignored). The last letters of the long words in the left column, that doe´nt fit, are just moved to the next line.

Now I open the file in Word, make a small change and save it. When I do the conversion again, the "square" i back.

Either way, the soft linebreak isn´t renderd correctly in the pdf. Are you getting correct soft linebreaks after you have open and saved it with Word - or are you getting no soft linebreaks att all in the pdf? Do you get the messed up layout?

I examined the content of the Aspose.Words document object after I loaded the word document. The (char)31 is there (see attatched image).
If I save it as Aspose.Pdf(xml), the content looks like this:
<Text MarginTop="6" MarginBottom="6" IsSpaced="true" LineSpacing="1.65">
<Segment FontName="FuturaMedium" FontSize="11">Lantmteri</Segment>
<Segment FontName="FuturaMedium" FontSize="11">kostnader</Segment>
</Text>

I get the exact same result with my file and the file you opend in your version of Word. It seems like the pdf part of the Aspose.Words component does´nt recognize the soft linebreak.

Does anything of this make sense? =)

Hi

<?xml:namespace prefix = o ns = "urn:schemas-microsoft-com:office:office" />

Thank you for additional information. Yes you are right, open/save using MS Word just help us to avoid “square”. So you should wait for a fix of the original issue. You will be notified as soon as it is fixed.

Best regards,

The issues you have found earlier (filed as 12163) have been fixed in this update.


This message was posted using Notification2Forum from Downloads module by aspose.notifier.
(2)

So I´ve tried the new 9.6.0 and I still get the “squares”.

The original file and the produced pdf is attatched.


wordsLicense = new Aspose.Words.License();
wordsLicense.SetLicense(licensePath);

Document doc = new Document(docPath, new LoadOptions()
{
LoadFormat = LoadFormat.Doc
});

doc.Save(pdfPath);

Hi

<?xml:namespace prefix = o ns = "urn:schemas-microsoft-com:office:office" />

Thanks for your request. I apologize for inconvenience. I see the problem with optional hyphen still exists. We will let you know once it is resolved.

Best regards,

The issues you have found earlier (filed as WORDSNET-3381) have been fixed in this .NET update and in this Java update.


This message was posted using Notification2Forum from Downloads module by aspose.notifier.
(1)