We're sorry Aspose doesn't work properply without JavaScript enabled.

Free Support Forum - aspose.com

Page numbers in slide master missing from save as multi-page tiff

Hi,

I’m trying to export a .ppt file as a multi-page tiff using the Aspose.Slides.Presentation.Save() method, however I’m having some issues with page numbers saved in the slide master, they are displayed as a star instead of a number, or the number is wrong. The issue is not present when processing a .pptx file. I have attached a file with which this issue can be seen. The page number is indicated in the slide master, and there are two slides. When saving out to a multi-page tiff, on the first slide the number is replaced with a *, on the second slide the number 2 is replaced with the number 1. If the ppt file is saved as a pptx the tiff is correctly rendered. Any ideas why this is going wrong?

Thanks,

Tom

Hi Tom,

I have worked with the sample presentation shared by you using Aspose.Slides for .NET 8.3.0 on my end. I have not been able to observe the issue specified. Can you please try using the specified version on your end by using following sample code. For your kind reference, I have also attached the generated tiff as well.

Presentation presentation = new Presentation(path + “Slide one Title.ppt”);
presentation.Save(path + “Slide one Title.ppt.tiff”, SaveFormat.Tiff);

Many Thanks,

Hi, I am using Aspose.Slides 14.1.0.0 are you able to reproduce the issue with this version? Thanks. Tom

Hi Tom,

I have worked with the presentation using the specified version on my end and have been able to observe the issue specified. I have created an issue with ID SLIDESNET-35073 in our issue tracking system to further investigate and resolve the issue. This thread has been linked with the issue so that you may be automatically notified once the issue will be resolved.

As I shared with you in my earlier post that with Aspose.Slides for .NET 8.3.0, there is no issue; so I suggest you to please use the specified version for the time being.

We are sorry for your inconvenience,

Hi,

We are unable to use the 8.3.0 version as it has another issue that the 14.1.0.0 version partially resolves http://www.aspose.com/community/forums/524811/aspose.slides-for-.net-image-extraction/showthread.aspx#524811 and our code is not compatible with the older version due to the namespace differences.

Why are there two versions in use at the same time? Which is the current version/branch?

Regards,

Tom

Hi Tom,

I am sorry for your inconvenience. We are maintaining the two versions on our end just for one quarter. By end of March, 2014, we will only be maintaining only merged Aspose.Slides for .NET 14.x.x API.

Actually, Aspose.Slides for .NET 8.x.x series old legacy API that has separate namespaces for PPT and PPTX presentation files. Whereas, Aspose.Slides for .NET 14.x.x is new merged API which provide single namespace for both PPT and PPTX. We are maintaining the two API together for one quarter till end of March 2014 and after this we will no longer be supporting old legacy Aspose.Slides for .NET API.

I will share the feedback with you as soon as the issue will be resolved.

Many Thanks,

The issues you have found earlier (filed as SLIDESNET-35073) have been fixed in this update.


This message was posted using Notification2Forum from Downloads module by Aspose Notifier.

The issues you have found earlier (filed as ) have been fixed in this update. This message was posted using BugNotificationTool from Downloads module by MuzammilKhan