Free Support Forum - aspose.com

Parameter is not valid on savig word document

We are using Aspose.Words for .Net in version 17.9.0.0.
On some instances of our application we randomly getting following exception:
AsposeGeneratingException.png (29.6 KB)

We cannot find any cause for this error. Problem is that we cannot reproduce the same error in our test system, but in production this error is happening occasionally.
Sometimes error is occurring multiple times in a row and then after a couple attempts document is generated correctly without any changes.
Could you please assist us in resolving this problem, or suggest what could be the problem?

@milanVr,

Please completely remove old version of Aspose.Words for .NET from your project. Clean the project. And then do a fresh installation of the latest version of Aspose.Words for. NET via NuGet. Hope this helps.

Installing Aspose.Words for .NET through NuGet

Hello
We are still having the same problem. We have tried suggested solution.
Project is using only Aspose.Words for. NET via NuGet.
We have cleaned production system of all old version of application with previous version of Aspose.Words for. NET.
Also problem occurred on completely new installations of system and our application.

However we have some additional details about when error occur. Namely it happened when document is saved as PDF.
Please note that the problem is occurring occasionally. When problem is present, for some time no document can be saved as PDF (in the same time document can be saved as word document). Users are complaining that sometimes problem is worsen. We cannot correlate problem with current load in the system or to some other process. Problem occurred in different times to just one user or to multiple users working in the same time.

@milanVr,

Please provide us complete steps that we can follow on our end to reproduce the same problem. What OS are you getting this problem on (please share environment details). Also, please ZIP and attach the following resources here for testing:

  • Your simplified input Word document you are getting this problem with
  • Please also create a standalone simple console application (source code without compilation errors) that helps us to reproduce your problem on our end and attach it here for testing. Please do not include Aspose.Words.dll files in it to reduce the file size.

We will then start further investigation into your issue and provide you more information. Thanks for your cooperation.