We're sorry Aspose doesn't work properply without JavaScript enabled.

Free Support Forum - aspose.com

PCL to PDF and special graphics characters

Hello, we are using aspose version 4 (aspose-pdf-jdk14.jar) to convert a pcl to pdf. The pcl file path is sent to the aspose library in order for it to make the conversion using the following line of code Document doc = new Document(pclFilePath, new PclLoadOptions());.

The issue is that the pcl file contains graphics characters that are meant to draw a table, those characters are not converted properly.

Below are the list of hex value of the characters:
"\u00c9", “\u00c8”, “\u00d1”, “\u00c7”, “\u00c5”, “\u00cf”,"\u00b6", “\u00bb”, “\u00bc”, “\u00cd”, “\u00c4”, “\u00ba”.

I am attaching an image of the actual output and the expected output.

Awaiting your reply.

Hi Khaled,


Thanks for contacting support.

Please share the resource PCL file so that we can test the conversion in our environment. We are sorry for your inconvenience.

I attached a sample PCL file that Khaled used. Please notice that we are selecting the PC-8 symbol set using the sequence ESC (10U.

Hi Eric,


Thanks for sharing the resource file.

<span style=“font-size:10.0pt;font-family:“Arial”,“sans-serif””>I
have tested the scenario and I am able to reproduce the same problem. For the
sake of correction, I have logged it in our issue tracking system as PDFNEWJAVA-34749. We
will investigate this issue in details and will keep you updated on the status
of a correction. <o:p></o:p>

We apologize for your inconvenience.

Is there any update on this issue? It’s been more than a month.

Hi Eric,


Thanks for your inquiry. I am afraid your reported issue is not resolved at the moment due to other issues already under investigation and resolution. We will notify you as soon as we made some significant progress towards issue resolution progress.

We are sorry for the inconvenience caused.

Best Regards,

This has been open for seven months. Is there any update?

Hi Eric,


Thanks for your inquiry. I am afraid your reported issue is still not resolved as product team is busy in resolving other issues in the queue, reported earlier. However I have raised the priority of your issue and requested our team to share ETA at their earliest. We will notify you as soon as we made some significant progress towards issue resolution.

We are sorry for the inconvenience caused.

Best Regards,
It appears that the problem is related to how Aspose treats file encoding. It seems to be converting bytes to characters by treating each byte as the low byte in a unicode-16 character, and setting the high byte to 0. Instead, the bytes need to be converted to characters based on the currently active symbol set. A common default for the symbol set on many printers seems to be IBM437, but that can be changed by an escape sequence anywhere within the PCL file.


It’s not just graphics characters that appear incorrectly. Accented characters don’t work either.


The character 0x82 is an accented e in symbol set 437. The sequence ESC-(10u should select that symbol set, and then any following 0x82 characters should appear as accented e (é). Instead, the character does not appear at all.

I attached a sample PCL file, that contains a series of accented e characters. The output should look like this:



Hi Eric,


Thanks for contacting support.

As per my observations, the extension of files shard earlier is .avi and once I have converted the file to .pcl and have tried converting it to PDF format using Aspose.Pdf for Java 10.8.0, the applications hangs and no resultant file is generated. Can you please share the code snippet and details on how you are trying to convert PCL file to PDF format. We are sorry for your inconvenience.


PS, if you are also getting application hang issue, please acknowledge so that we can further look into this matter from this perspective.

I removed the leading ESC(10u escape sequence from the file, which seemed to cause the problem. I attached the new version, and a simple Java test.



Hi Eric,


Thanks for sharing the new file.

I have again tested the conversion using Aspose.Pdf for Java 10.8.1 while using following code snippet and as per my observations, a blank resultant file is being generated. For your reference, I have also attached the output generated over my end.

[Java]

Document doc = new Document(“c:/pdftest/accentede_new.pcl”, new
com.aspose.pdf.PclLoadOptions());
<o:p></o:p>

doc.save("c:/pdftest/accentede_new.pdf");

So you were able to reproduce the problem, then. It should be showing several lines of accented e (é ) characters, but you are getting a blank page instead. I don’t know for certain if this is the same problem as the problem with line-drawing characters, but I think they might be related.

Hi Eric,


Thanks for your patience.

As shared earlier, when converting earlier shared accentede.avi (I renamed file extension to .pcl), the resultant file being generated is blank. However when using same code snippet to convert ld.pcl file shared earlier in this thread, the output file is not blank and I can see contents inside it. It appears that something is getting wrong during file sharing or when I am converting file extension to .pcl format. Can you please archive the actual PCL file and attach in this thread. We are sorry for this inconvenience.

Why are you assuming there is a file sharing problem? It sounds like you are reproducing the exact problem. One file contains all accented e characters, which when processed show up as blank. The other file contains line drawing characters, which when converted appear as the wrong characters.

Hi Eric,


Thanks for sharing the feedback. Now my understanding is that when converting PCL file containing accented characters to PDF format, no information is displayed in resultant file. For the sake of correction, I have logged this problem
as PDFNEWJAVA-35305 in our issue tracking system. We will
further look into the details of this problem and will keep you updated on the
status of correction. Please be patient and spare us little time. We are sorry
for this inconvenience.

The issues you have found earlier (filed as PDFNEWJAVA-34749) have been fixed in Aspose.Pdf for Java 11.3.0.


This message was posted using Notification2Forum from Downloads module by Aspose Notifier.