We're sorry Aspose doesn't work properply without JavaScript enabled.

Free Support Forum - aspose.com

PDF-Convert

Hello!

I’m using your products to convert Word-files to PDF (pretty much the way you suggest in http://www.aspose.com/documentation/file-format-components/aspose.pdf-for-.net-and-java/converting-word-documents-to-pdf.html).

It all works fine, except that embedded worksheet-objects are converted to bitmaps instead of text (like other converters do).

Is there a way to make that work, too?

Our Word-files are always the same, but we recognized a change in the PDF-output in the last few days. The resolution of the bitmap got worse. I don’t think that we changed anything, so I have no idea why that happened. And that’s really bad and we need a fast solution here.

Sincerely,
Harald Außerhofer

Hello Harald,

Thanks for considering Aspose.

It is a known issue that, resolution of the image in resultant Pdf, generated from Word file is not good as compare to the input Word file. We are working over this problem, but I am afraid we cannot support this in short time. We apologize for your inconvenience.

OK. But why did it change a few days ago? It was not very good, but fair enough until then (we use the same conversion with the same kind of files for a few months already). Now you nearly can’t read the 10pt Arial text of the embedded Excel.

Hello harald,

Sorry for causing the confusion in previous post. I have confirmed from the development team that it’s not an issue of the resolution of picture in converted Pdf. The reason is that the embedded worksheet-objects are not supported and Aspose.Words converts it into bitmap as workaround.

We need to contact Aspose.Words team, if we can support it in better way. We will keep you updated with the status of correction.

Hello Nayyer!

If it had not worked in the first place, I wouldn’t have a problem, but since it worked a quite long time (where the worksheet-object was converted as well) and it does not work anymore (because the quality changed without any known reason), it’s really hard for me to argue with our customers.

Harald

Hi Harald,

Sorry for replying to you late.

Can you please provide the Word document and let us check it? Please also tell us it since which version is does not work well.

Hi!

I cannot send you the original Files. But I created a testfile. As you can see, the letters and numbers inside of the table don't look very good.

I did not change the version (that would have been easy, I just could use the working version)! I don't know what caused the change in the behaviour of the whole thing.

Hello Harald,

<?xml:namespace prefix = o ns = "urn:schemas-microsoft-com:office:office" />

I have tested the issue using Aspose.Words 5.2.2.0 and latest hotfix for Aspose.Pdf 3.8.0.3 and in my case the resultant Pdf is much better. I can easily read the text. I have also attached the resultant Pdf that I have generated.

You can download the latest hotfix of Aspose.Pdf 3.8.0.3 from 146148 thread.

Hello Nayyer!

I used version 5.1 of the Aspose.Words and now updated to your versions and it seems to work again.

I still think it's kind of weird...

Harald

Harald,

<?xml:namespace prefix = o ns = "urn:schemas-microsoft-com:office:office" />

We need to look into the details of this matter, and for correction purpose we may also need to contact Aspose.Words team. Please spare us some time. Your patience in this regard is highly appreciated.

Hi!

With the new versions, my problem is solved for now (hopeing it will not occur again).

Maybe following information is useful for you: First I changed the pdf dll to 3.8.0.3 but that didn't help. It only worked after I also changed the word dll.

Yours,

Harald

Dear Harald,

I have checked the issue with different versions of both Aspose.Pdf(3.6.2.2, 3.8.0.3) and Aspose.Words(5.1.0.0, 5.2.0.0, 5.2.2.0). In my investigation, the results depend on the version of Aspose.Words. It only works when using Aspose.Words 5.2.2.0. I think the resolution problem should be a fixed bug in Aspose.Words. It would be okay to update to new versions of Aspose.Words. Thanks.

Best regards.