PDF generated by Aspose.PDF is not readable by Acrobat


#1

We currently own Aspose.Word and are looking into generating PDFs from our word documents. I have the latest version of both Aspose.Word (2.0.2) and Aspose.PDF (2.0.3 Trial) but I'm having some strange problems. Here's what I did:

I created a test windows application in Visual Studio .NET that references both the Aspose.Word and Aspose.PDF assemblies. One button on the form generates the xml file from a word document. Another button generates the PDF document from the xml file. When I tested this using a 7 page word document it seemed to work fine, except for all the random text and warnings that say "Evaluation Only... etc."

Because I had a word license file handy, I added a line of code to the first button click to set the license and then changed my assembly company value to the proper string.

When I ran this code, it generated the xml and pdf file as before but when I went to view the PDF, I got an error from Acrobat saying:

"There was an error processing a page. There was a problem reading this document (110)."

When I click OK on the error message, Acrobat displays the pdf but the first page is entirely blank while pages 2-7 have the proper text.

Why would setting the license file for Word cause this to happen?

I will try to provide the word document that caused this problem to you in a following post.

Thanks,

Steve


#2

It turns out I have a table of contents field on the first page that was the culprit. I took this field out and then regenerated the pdf with the word license set and it worked ok this time.

How come the table of contents would work when the word license is not set?

Also, does the Aspose.PDF generation process not support these special Table of Content fields (this field is like a merge field – whenever i tell it to update it looks for all the outline headers in the word document and lists them in the proper order with the page number that they are on)?

Steve


#3

Hi Steve,

Thank you for considering Aspose.

Can you please send the Word document to me?