PDF layout in table is different from DOCX


#1

Hi guys,


I use AW 11.0.0.0 and got a problem recently - the text layout in tables are different in DOCX vs PDF output.
In attached documents in last table please have a look in the header of the second column: in word it is in 3 lines, in PDF in 2 lines. Next, the 3d column - it fits to the word Development in DOCX while in PDF it moves the letter t on the next line.

Regards,
Alex

#2

Hi Alex,

Thanks for your query. I have tested the scenario and have managed to reproduce the same problem at my end. I have logged this issue in our issue tracking system and you will be notified via this forum thread once this issue is resolved.


#3

Hi Tahir,


Any progress or at least estimates on this issue?
I’ve recently got another one which is similar but could be different. If you have a look in attached documents in PDF Net Assets one line table is moved to second page of document while in MS word it is on the 1st page. The layout of tables on a page and the consistency of Word-PDF output is a pretty crucial requirement from our customer so I wonder if there is a workaround to avoid this issue (or if it is a defect what could be ETA for fix)?
Regards,
Alex

#4

Hi Alex,

I have verified the status of this issue from our issue tracking system. This issue is pending for analysis and is in the queue. You will be updated via this forum thread once this issue is resolved. This issue ID is WORDSNET-5990.

Regarding your second question (Net Assets on second page), Please see the attached image file. The Net Assets is not on the same page. Please share some more information about your query for investigation purposes.

I really appreciate your patience.


#5

Hi Tahir,


Please find attached a screenshot made on my computer.

#6

Hi Alex,

It would be great if you please share your working enviornment like Operating System, MS Office etc. for investigation purposes.


#7

Hi Tahir,


Sure I had to figure out myself that it could be environment related and provided you with the information earlier.
Windows 7 Professional SP1 64
MS Office 2007 SP3
Regards,
Alex


#8

Hi Alex,

Please accept my apologies for late response.

I have tested the the same scenario at following environment and have found that the
Net Assets is at page number 3. It would be great if you please convert your document to Pdf by using MS Words and share that output.pdf with us for investigation purpose.

Windows 7 Professional SP1 64
MS Office 2007 SP3


#9

Hi Tahir,


Please find requested file attached. Net assets are on the same page as in MS Word file opened on my laptop (which is expected behavior).

Regards,
Alex

#10

Hi Alex,

Thanks for sharing the file. The shared Docx file (ReportTest.docx) has one empty line space at the start of second page. I have removed this line and converted docx to Pdf file with correct output. Please find the input and output files in attachment.

Please let us know if you have any more queries.


#11

Hi Tahir,


Thank you for your reply. I am afraid I am a bit lost with your last reply. There is indeed empty line before the table. The document is built automatically and the reason for this line is to separate a table’s header from a header. The problem is that having built the AW document I export it into 2 formats: docx and PDF and the output is different. My understanding is that layout is calculated incorrectly for a given AW model (maybe because of using nested tables). The question is not how to get the table on 2nd page in PDF but is it possible (and how if yes) to get the equal tables layout for both docs and PDF.

Regards,
Alex

#12

Hi Alex,

Thanks for sharing the feedback. Please share MS office version which you are using. I am using MS office version :

MS Word 2007 (12.0.6661.5000) SP3 MSO (12.0.6607.1000)


#13

Hi Tahir,


Yep, I am on the same version. If you have a test build with logging turned on I can run it and collect the logs.

Regards,
Alex

#14

Hi Alex,

Thanks for sharing the information. I have noticed that the screen shot you shared (Capture.PNG) have “Section Break (Continuous)” but the shared document has not this section break after “Net Assets” text.

Please share your document from which you had taken the screen shot (
Capture.PNG) for investigation purposes.

I have attached the document which you had shared with us earlier. This document is without
Section Break (Continuous)” after text “Net Assets”.


#15

Hi Tahir,


It’s a kind of magic but both document in zip and the one you attached have the Section Break (at least I see it when open any of them). Sounds pretty weird for me.
Regards,
Alex

#16

Hi Alex,

I have worked with your document at same environment and have found that the text
Net Assets” is on the third page. Please convert your document to Docx and Doc format and share the output files with us for investigation purposes.

We are sorry for your inconvenience.


#17

Hi Tahir,


Sorry for late response, please find doc file attached. Docx file is in original zip archive.

Regards,
Alex

#18

Hi Alex,

Thanks for sharing the document. This document has text “Net assets” at second page. Please see the attachment. I have opened this document in MS Office 2003, 2007, 2010 and open office. The text
“Net assets” is at second page. It would be great if you please open this file in Open Office and share your finding with us.


#19

Hi Tahir,


It looks like there is a misunderstanding between us caused by my typo. In very first post regarding to this issue I wrote “1st page in word document and second page in PDF” though in fact it was 2nd page in word document and 3d page in pdf. So the problem is that Net Assets “stays” on a Word’s page while in PDF it “moves” to the next one. Though from our further thread I got the understanding that you had seen the problem (different Word/PDF page layout for Net Assets) and you tried to reproduce this issue in Word on your side. Now you were able to reproduce the problem - Net Assets is on 2nd page in Word and 3d page in PDF on your computer so what findings do you expect me to find having opened the document in Open Office? I am afraid I am a bit lost.

Regards,
Alex

#20

Hi Alex,

I have converted the shared doc and docx files to Pdf by using latest version of Aspose.Words for .NET. Please find the output Pdf files in attachment.
Followings are the output Pdf details.

The text “Net Assets” is at page number 2 in ReportTest.doc and ReportTest.doc.pdf

The text “Net Assets” is at page number 3 in ReportTest.docx and ReportTest.docx.pdf

I have requested another Aspose.Words support engineer to take a closer look at your problem. He will get back to you shortly.