We're sorry Aspose doesn't work properply without JavaScript enabled.

Free Support Forum - aspose.com

PDF to Excel Not Working

See the attached PDF, it’s a very simple test. The generated XLS is not complete.

com.aspose.pdf.Document pdfDocument = new com.aspose.pdf.Document(“c:/tools/test2.pdf”);
com.aspose.pdf.ExcelSaveOptions e = new com.aspose.pdf.ExcelSaveOptions();

pdfDocument.save(“c:/tools/ConvertedFile.xls”, e);

Using aspose.pdf-10.9.0.jar

Hi Joey,


Thanks for contacting support.

The problem is occurring because you are using the API in trial mode. Because during my testing while using valid license, I am unable to notice any issue. The XLS generated over my end is also attached.

In order to test our API’s without any limitations, please visit the following link to Get a temporary license

Thanks. That did allow this simple example to generate successfully.

The PDF I actually need to convert is much more complicated. I ran it through the PDF-to-Excel converter and it worked but it did not maintain all of it’s formatting.

It seems that anywhere in the PDF table that there is a line break, aspose PDF makes it a new cell. See the attached example.png.


If the formatting (bold and borders) could be maintained, line breaks not make new cells, and columns expand to the width of the largest cell, I would have exactly what I need.

Are there options to enable any of these features?

Hi Joey,


Thanks for your feedback and it is good to know that now your above shared(simple) document rendered as expected.

Furthermore in reference to complex PDF, I am afraid there is not such options to maintain the formatting. We will appreciate it if you please share that problematic PDF document here. We will look into the issue and will guide you accordingly.

We are sorry for the inconvenience caused.

Best Regards,