Free Support Forum - aspose.com

PDF to Excel, Result Differs between Online / Local Versions

We have used Online version (https://products.aspose.app/pdf/zh/conversion) to convert PDF to Excel, and the result is good.

Then we tried evaluating Local version (from https://github.com/aspose-pdf/Aspose.PDF-for-.NET), the result Excel has some offsets between cells.

We would like to have the same result as from the Online version. Is there anything we can do? Is paid version has the same issue?

@kmtong

Could you please share your sample PDF document with us so that we can also test the scenario in our environment and address it accordingly.

This is the different result: compare.png (62.0 KB)

This is the source PDF: 25-1-42.吉迩科技24件.pdf (327.0 KB)

@kmtong

Please check the attached output XLSX which we obtained using Aspose.PDF for .NET 20.12 and the following code snippet:

Document pdfDocument = new Document(dataDir + "25-1-42.吉迩科技24件.pdf");
Aspose.Pdf.ExcelSaveOptions excelsave = new ExcelSaveOptions();
excelsave.Format = ExcelSaveOptions.ExcelFormat.XLSX;
pdfDocument.Save(dataDir + "output20.12.xlsx", excelsave);

output20.12.zip (17.5 KB)

We did not notice any issue in the output Excel file as you mentioned. Would you please make sure to use the latest version of the API and in case you still face any issue, please let us know.

Also, please make sure to use a valid license or a 30-days free temporary license while evaluating the API.

Thanks for your response.

But your attached file is the same as the picture at right-hand-side part of previous attached file “compare.png”. Notice the staircase pattern recognized compared with the online version (at the left-hand-side part of “compare.png”)

@kmtong

We apologize for the confusion.

Yes, we were able to notice the similar issue in the generated Excel file using Aspose.PDF for .NET 20.12. We have logged an investigation ticket as PDFNET-49244 in our issue tracking system to further analyze the reasons behind this issue. We will further look into its details and keep you posted with the status of its correction. Please be patient and spare us some time.

We are sorry for the inconvenience.

@kmtong

Upon initial investigation, it is found that this is a regression that appeared in version 20.11 (the online version used some early version). Please try to use version 20.10 while this bug is not fixed. We will update you in this forum thread as soon as the issue is fixed.

We apologize for the inconvenience.