We're sorry Aspose doesn't work properply without JavaScript enabled.

Free Support Forum - aspose.com

PDF to PDF/A Conversion - Aspose PDF 4.x

Hi,

we are trying to use the latest release of Aspose.PDF for java (version 4.0.0) to convert a simple PDF file to a PDF/A-1b compliant PDF.

We used the following code:

com.aspose.pdf.Document pdfDocument = new com.aspose.pdf.Document(fileIn);

pdfDocument.convert(fileLog, com.aspose.pdf.PdfFormat.PDF_A_1B, com.aspose.pdf.ConvertErrorAction.Delete);

com.aspose.pdf.PdfSaveOptions so = new com.aspose.pdf.PdfSaveOptions();

pdfDocument.save(fileOut,so);

However the result is always a standard PDF (no PDF/A).

We tried the new 4.1.2 release but it gave us the same result.

We also tried to convert a PDF/A-1a into PDF/A-1b but even in this case the resulting PDF is only a standard PDF.

Is the PDF to PDF/A conversion currently implemented in the java version? If not when will it be ported from the .NET version?

Is there an alternative way to accomplish this conversion?

Thank you!

Hi there,

Sorry for the inconvenience faced. While using the latest version of Aspose.Pdf for Java 4.1.2, I've managed to reproduce this issue on my side and logged the issue in our bug tracking system as PDFNEWJAVA-33606 for further investigation and resolution. I've also linked your request to this issue and you will be notified via this thread as soon as it is resolved.

Please feel free to contact us for any further assistance.

Best Regards,

The issues you have found earlier (filed as PDFNEWJAVA-33606) have been fixed in this update.


This message was posted using Notification2Forum from Downloads module by Aspose Notifier.
(4)